summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-04 15:33:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-09 14:47:47 +0200
commit31476df32e1d5194f4f7085bba487681cc250e38 (patch)
tree473706eef498af289bec8a5390e52c1e89e81aa9 /gnu/packages/graph.scm
parente57fffad90a87d8ac38e4ac44ac5b5eb2d7bd191 (diff)
downloadguix-31476df32e1d5194f4f7085bba487681cc250e38.tar.gz
gnu: Add python-igraph.
* gnu/packages/graph.scm (python-igraph): New variable.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 54b0962b68..b379bfdd03 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -20,11 +20,13 @@
   #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xml))
 
 (define-public igraph
@@ -60,3 +62,23 @@ It can handle large graphs very well and provides functions for generating
 random and regular graphs, graph visualization, centrality methods and much
 more.")
     (license license:gpl2+)))
+
+(define-public python-igraph
+  (package (inherit igraph)
+    (name "python-igraph")
+    (version "0.7.1.post6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-igraph" version))
+       (sha256
+        (base32
+         "0xp61zz710qlzhmzbfr65d5flvsi8zf2xy78s6rsszh719wl5sm5"))))
+    (build-system python-build-system)
+    (arguments '())
+    (inputs
+     `(("igraph" ,igraph)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://pypi.python.org/pypi/python-igraph")
+    (synopsis "Python bindings for the igraph network analysis library")))