summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-18 17:50:19 +0100
committerMarius Bakke <marius@gnu.org>2022-01-18 19:35:55 +0100
commit38fdd118d0bcfcff47632ec28f89a4f5fc1dd8a1 (patch)
tree95c3ca3509a78802ed905fa719443bfca513e66a /gnu/packages/graph.scm
parent206c79df39a0cc6777c6ba5cac68ee1b7d5f285e (diff)
downloadguix-38fdd118d0bcfcff47632ec28f89a4f5fc1dd8a1.tar.gz
gnu: python-leidenalg: Fix build failure.
* gnu/packages/graph.scm (python-leidenalg)[arguments]: Add #:phases.
[native-inputs]: Add PYTHON-SETUPTOOLS.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 30027c9827..095fe1c9d1 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
 ;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -474,9 +475,18 @@ Faiss library.")))
         (base32
          "15fwld9hdw357rd026mzcwpah5liy4f33vc9x9kwy37g71b2rjf1"))))
     (build-system python-build-system)
-    (arguments '(#:tests? #f)) ; tests are not included
+    (arguments
+     '(#:tests? #f                      ;tests are not included
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-requirements
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("python-igraph >=")
+                         "igraph >=")))))))
     (native-inputs
-     (list pkg-config))
+     ;; XXX: setuptools >= 58 as shipped with Python 3.9+ removes support
+     ;; for lib2to3, so use this older variant.
+     (list pkg-config python-setuptools))
     (inputs
      (list igraph))
     (propagated-inputs