summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-14 18:07:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-14 21:39:16 +0200
commitb3a998374c37964820a51182fa7be7a546fc4d46 (patch)
tree9d687b72ef789a12186cd1255ea3f560c88665f6 /gnu/packages/graph.scm
parent6e0ab26f31cd2bb7e5d88719d3d458df68c1963e (diff)
downloadguix-b3a998374c37964820a51182fa7be7a546fc4d46.tar.gz
gnu: r-rgraphviz: Move to (gnu packages bioconductor).
* gnu/packages/graph.scm (r-rgraphviz): Move from here...
* gnu/packages/bioconductor.scm (r-rgraphviz): ...to here.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index ccffccb050..db390fed5e 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -121,44 +121,6 @@ more.")
     (home-page "https://pypi.org/project/python-igraph/")
     (synopsis "Python bindings for the igraph network analysis library")))
 
-(define-public r-rgraphviz
-  (package
-    (name "r-rgraphviz")
-    (version "2.32.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "Rgraphviz" version))
-       (sha256
-        (base32
-         "1calpvzgcz6v7s4x6bf35kj83sga95zjp7x87p5d3qnbv7q2wz5y"))))
-    (properties `((upstream-name . "Rgraphviz")))
-    (build-system r-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'make-reproducible
-           (lambda _
-             ;; The replacement value is taken from src/graphviz/builddate.h
-             (substitute* "src/graphviz/configure"
-               (("VERSION_DATE=.*")
-                "VERSION_DATE=20200427.2341\n"))
-             #t)))))
-    ;; FIXME: Rgraphviz bundles the sources of an older variant of
-    ;; graphviz.  It does not build with the latest version of graphviz, so
-    ;; we do not add graphviz to the inputs.
-    (inputs `(("zlib" ,zlib)))
-    (propagated-inputs
-     `(("r-graph" ,r-graph)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (home-page "https://bioconductor.org/packages/Rgraphviz")
-    (synopsis "Plotting capabilities for R graph objects")
-    (description
-     "This package interfaces R with the graphviz library for plotting R graph
-objects from the @code{graph} package.")
-    (license license:epl1.0)))
-
 (define-public r-rbiofabric
   (let ((commit "666c2ae8b0a537c006592d067fac6285f71890ac")
         (revision "1"))