summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2021-04-21 17:59:32 +0200
committerLeo Famulari <leo@famulari.name>2021-04-21 12:17:30 -0400
commit823752646f4992efdd4162724b46e04dda8b660a (patch)
tree99dd5309fda3929fd29963585ba6e9ea06383354 /gnu/packages/graphics.scm
parent969b80ef604a78c8592e3b94767c8bb736d4bcca (diff)
downloadguix-823752646f4992efdd4162724b46e04dda8b660a.tar.gz
gnu: Blender: Add the missing Voxel Remesher.
* gnu/packages/graphics.scm (blender)[inputs]: Add openvdb.
[arguments]: Pass "-DWITH_OPENVDB=ON" to #:configure-flags.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f9f19cc28d..ef3be67b25 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -527,6 +527,7 @@ typically encountered in feature film production.")
                "-DWITH_INSTALL_PORTABLE=OFF"
                "-DWITH_JACK=ON"
                "-DWITH_MOD_OCEANSIM=ON"
+               "-DWITH_OPENVDB=ON"
                "-DWITH_OPENSUBDIV=ON"
                "-DWITH_PYTHON_INSTALL=OFF"
                (string-append "-DPYTHON_LIBRARY=python" ,python-version)
@@ -582,6 +583,7 @@ typically encountered in feature film production.")
        ("pugixml" ,pugixml)
        ("python" ,python)
        ("python-numpy" ,python-numpy)
+       ("openvdb" ,openvdb)
        ("tbb" ,tbb)
        ("zlib" ,zlib)
        ("embree" ,embree)))