summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-03 14:17:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-03-07 20:58:25 +0100
commit0e2f2aebedef8b90750cc6aec9d5840def22e921 (patch)
tree65b30956b74735a6f009b6a174931b9716d2921f /gnu/packages/graphics.scm
parent201cfb81d112f98bb7240d5924fcab9fca955177 (diff)
downloadguix-0e2f2aebedef8b90750cc6aec9d5840def22e921.tar.gz
gnu: Add Blender.
* gnu/packages/graphics.scm (blender): New variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm85
1 files changed, 85 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3fdf07d361..c022d74ca2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,6 +27,8 @@
   #:use-module (guix build-system cmake)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
+  #:use-module (gnu packages algebra)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages boost)
@@ -33,14 +36,96 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pulseaudio)  ;libsndfile, libsamplerate
   #:use-module (gnu packages compression)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages jemalloc)
+  #:use-module (gnu packages photo)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sdl)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xorg))
 
+(define-public blender
+  (package
+    (name "blender")
+    (version "2.76b")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.blender.org/source/"
+                                  "blender-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pb0mlj4vj0iir528ifqq67nsh3ca1942933d9cwlbpcja2jm1dx"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(;; Test files are very large and not included in the release tarball.
+       #:tests? #f
+       #:configure-flags
+       (list "-DWITH_CODEC_FFMPEG=ON"
+             "-DWITH_CODEC_SNDFILE=ON"
+             "-DWITH_CYCLES=ON"
+             "-DWITH_DOC_MANPAGE=ON"
+             "-DWITH_FFTW3=ON"
+             "-DWITH_GAMEENGINE=ON"
+             "-DWITH_IMAGE_OPENJPEG=ON"
+             "-DWITH_INPUT_NDOF=ON"
+             "-DWITH_INSTALL_PORTABLE=OFF"
+             "-DWITH_JACK=ON"
+             "-DWITH_MOD_OCEANSIM=ON"
+             "-DWITH_PLAYER=ON"
+             "-DWITH_PYTHON_INSTALL=OFF"
+             "-DWITH_SYSTEM_OPENJPEG=ON")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-broken-import
+           (lambda _
+             (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
+               (("import encode_bin") "from . import encode_bin"))
+             #t))
+         (add-after 'set-paths 'add-ilmbase-include-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; OpenEXR propagates ilmbase, but its include files do not appear
+             ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
+             ;; the CPATH to satisfy the dependency on "half.h".
+             (setenv "CPATH"
+                     (string-append (assoc-ref inputs "ilmbase")
+                                    "/include/OpenEXR"
+                                    ":" (or (getenv "CPATH") "")))
+             #t)))))
+    (inputs
+     `(("boost" ,boost)
+       ("jemalloc" ,jemalloc)
+       ("libx11" ,libx11)
+       ("openimageio" ,openimageio)
+       ("openexr" ,openexr)
+       ("ilmbase" ,ilmbase)
+       ("openjpeg" ,openjpeg-1)
+       ("libjpeg" ,libjpeg)
+       ("libpng" ,libpng)
+       ("libtiff" ,libtiff)
+       ("ffmpeg" ,ffmpeg)
+       ("fftw" ,fftw)
+       ("jack" ,jack-1)
+       ("libsndfile" ,libsndfile)
+       ("freetype" ,freetype)
+       ("glew" ,glew)
+       ("openal" ,openal)
+       ("python" ,python-wrapper)
+       ("zlib" ,zlib)))
+    (home-page "http://blender.org/")
+    (synopsis "3D graphics creation suite")
+    (description
+     "Blender is a 3D graphics creation suite.  It supports the entirety of
+the 3D pipeline—modeling, rigging, animation, simulation, rendering,
+compositing and motion tracking, even video editing and game creation.  The
+application can be customized via its API for Python scripting.")
+    (license license:gpl2+)))
+
 (define-public cgal
   (package
     (name "cgal")