summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-24 19:54:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-24 19:54:46 +0300
commit8a0384b88fb216e9beca37be929b7337faabf4cc (patch)
tree12a2076d301c2bcdaa10c2478590dc4fd1f07d64 /gnu/packages/graphics.scm
parente19b3d4003f62e7f50e9cd3fbe3d49169b47329f (diff)
downloadguix-8a0384b88fb216e9beca37be929b7337faabf4cc.tar.gz
gnu: openexr-2: Extend the test timeout.
* gnu/packages/graphics.scm (openexr-2)[arguments]: Adjust the custom
phase to extend the test timeout.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d4300f01da..4a404953a0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1173,13 +1173,13 @@ with strong support for multi-part, multi-channel use cases.")
                (("/var/tmp") "/tmp"))))
          (add-after 'change-directory 'increase-test-timeout
            (lambda _
-             ;; On armhf-linux, we need to override the CTest default
+             ;; On some architectures, we need to override the CTest default
              ;; timeout of 1500 seconds for the OpenEXR.IlmImf test.
              (substitute* "IlmImfTest/CMakeLists.txt"
                (("add_test\\(NAME OpenEXR\\.IlmImf.*" all)
                 (string-append
                  all
-                 "set_tests_properties(OpenEXR.IlmImf PROPERTIES TIMEOUT 2000)")))
+                 "set_tests_properties(OpenEXR.IlmImf PROPERTIES TIMEOUT 15000)")))
              #t))
          ,@(if (not (target-64bit?))
                `((add-after 'change-directory 'disable-broken-test