summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-21 01:02:05 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-21 01:19:58 -0500
commit6cae4e97927dd215bc5af84e7c4d938a26fb40c1 (patch)
treea651102f4e69655cafda75f501171b08eec18edf /gnu/packages/graphics.scm
parentae9333e7e3adbc4d199004a8c6910d7bc28628cb (diff)
downloadguix-6cae4e97927dd215bc5af84e7c4d938a26fb40c1.tar.gz
gnu: dear-imgui: Delete package, preferring the newer 'imgui'.
Commit 1a4cc954d2fcea172a450ae03419b7fdda28b81e added imgui, without noticing
about the pre-existing 'dear-imgui' package.

* gnu/packages/graphics.scm (dear-imgui): Delete variable, but salvage the
superior synopsis and description to...
* gnu/packages/toolkits.scm (imgui): ... here.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm70
1 files changed, 0 insertions, 70 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7c4c998310..04f92e2b07 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -839,76 +839,6 @@ other vector formats such as:
 @end itemize")
     (license license:gpl2+)))
 
-(define-public dear-imgui
-  (package
-    (name "dear-imgui")
-    (version "1.79")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/ocornut/imgui")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0x26igynxp6rlpp2wfc5dr7x6yh583ajb7p23pgycn9vqikn318q"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "PREFIX=" (assoc-ref %outputs "out"))
-             (string-append "VERSION=" ,version))
-       #:tests? #f                      ; no test suite
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-debian-files
-           (lambda* (#:key inputs #:allow-other-keys)
-             (invoke "tar" "xvf" (assoc-ref inputs "debian-files"))
-             (apply invoke "patch" "-Np1" "-i"
-                    (find-files "debian/patches" "\\.patch$"))
-             (substitute* "Makefile"
-               (("<stb/") "<")          ; Guix doesn't use this subdirectory
-               ;; Don't build or install the static library.
-               (("^all: .*") "all: $(SHLIB) $(PCFILE)"))
-             (substitute* (list "imgui.pc.in"
-                                "Makefile")
-               ;; Don't link against a non-existent library.
-               (("-lstb") ""))
-             #t))
-         (delete 'configure)            ; no configure script
-         (replace 'install
-           ;; The default ‘install’ target installs the static library.  Don't.
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "make" "install-shared" "install-header"
-                    make-flags))))))
-    (native-inputs
-     `(("debian-files"
-        ;; Upstream doesn't provide a build system.  Use Debian's.
-        ,(origin
-           (method url-fetch)
-           (uri (string-append "mirror://debian/pool/main/i/imgui/imgui_"
-                               version "+ds-1.debian.tar.xz"))
-           (sha256
-            (base32 "1xhk34pzpha6k5l2j150capq66y8czhmsi04ib09wvb34ahqxpby"))))
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     (list freetype stb-rect-pack stb-truetype))
-    (home-page "https://github.com/ocornut/imgui")
-    (synopsis "Immediate-mode C++ GUI library with minimal dependencies")
-    (description
-     "Dear ImGui is a @acronym{GUI, graphical user interface} library for C++.
-It creates optimized vertex buffers that you can render anytime in your
-3D-pipeline-enabled application.  It's portable, renderer-agnostic, and
-self-contained, without external dependencies.
-
-Dear ImGui is aimed at content creation, visualization, and debugging tools as
-opposed to average end-user interfaces.  Hence it favors simplicity and
-productivity but lacks certain features often found in higher-level libraries.
-It is particularly suited to integration in game engine tooling, real-time 3D
-applications, full-screen applications, and embedded platforms without standard
-operating system features.")
-    (license license:expat)))           ; some examples/ use the zlib licence
-
 (define-public alembic
   (package
     (name "alembic")