summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 21:40:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:05 -0400
commitaad73bb58edd03d448cc0c9c4fd209eda7976ec4 (patch)
tree881900d059e100b960b98511639c0c3d0512c833 /gnu/packages/graphics.scm
parent00dff2c76853980a70079fe682d184bb6ef16b03 (diff)
downloadguix-aad73bb58edd03d448cc0c9c4fd209eda7976ec4.tar.gz
gnu: Remove rapicorn.
* gnu/packages/graphics.scm (rapicorn): Delete variable.
* gnu/packages/patches/rapicorn-isnan.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm67
1 files changed, 0 insertions, 67 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4b07061fa1..64286bf68d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1361,73 +1361,6 @@ realistic reflections, shading, perspective and other effects.")
     (home-page "http://www.povray.org/")
     (license license:agpl3+)))
 
-(define-public rapicorn
-  (package
-    (name "rapicorn")
-    (version "16.0.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://testbit.eu/pub/dists/rapicorn/"
-                                  "rapicorn-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1y51yjrpsihas1jy905m9p3r8iiyhq6bwi2690c564i5dnix1f9d"))
-              (patches (search-patches "rapicorn-isnan.patch"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-tests
-           (lambda _
-             ;; Our grep does not support perl regular expressions.
-             (substitute* "taptool.sh"
-               (("grep -P") "grep -E"))
-             ;; Disable path tests because we cannot access /bin or /sbin.
-             (substitute* "rcore/tests/multitest.cc"
-               (("TCMP \\(Path::equals \\(\"/bin\"") "//"))
-             #t))
-         (add-before 'check 'pre-check
-           (lambda _
-             ;; The test suite requires a running X server (with DISPLAY
-             ;; number 99 or higher).
-             (system "Xvfb :99 &")
-             (setenv "DISPLAY" ":99")
-             #t))
-         (add-after 'unpack 'replace-fhs-paths
-           (lambda _
-             (substitute* (cons "Makefile.decl"
-                                (find-files "." "^Makefile\\.in$"))
-               (("/bin/ls") (which "ls"))
-               (("/usr/bin/env") (which "env")))
-             #t)))))
-    ;; These libraries are listed in the "Required" section of the pkg-config
-    ;; file.
-    (propagated-inputs
-     (list librsvg cairo pango libxml2 python2-enum34))
-    (inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("libpng" ,libpng-1.2)
-       ("readline" ,readline)
-       ("libcroco" ,libcroco)
-       ("python" ,python-2)
-       ("cython" ,python2-cython)))
-    (native-inputs
-     `(("pandoc" ,pandoc)
-       ("bison" ,bison)
-       ("flex" ,flex)
-       ("doxygen" ,doxygen)
-       ("graphviz" ,graphviz)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("xvfb" ,xorg-server-for-tests)))
-    (home-page "https://rapicorn.testbit.org/")
-    (synopsis "Toolkit for rapid development of user interfaces")
-    (description
-     "Rapicorn is a toolkit for rapid development of user interfaces in C++
-and Python.  The user interface is designed in a declarative markup language
-and is connected to the programming logic using data bindings and commands.")
-    (license license:mpl2.0)))
-
 (define-public ctl
   (package
     (name "ctl")