summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 02:22:34 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-30 00:56:59 +0100
commit5d014c696f88563ae95dec22ece8cd45b3a40862 (patch)
tree107f8c1ebdd53f08e8731d854a67752fe38abe74 /gnu/packages/graphics.scm
parent3690f6c7a923d680bb26e645377f5d14e21824be (diff)
downloadguix-5d014c696f88563ae95dec22ece8cd45b3a40862.tar.gz
gnu: Add alembic.
* gnu/packages/graphics.scm (alembic): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9a0b2d9c9a..574c498b7e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -936,6 +936,30 @@ applications, full-screen applications, and embedded platforms without standard
 operating system features.")
     (license license:expat)))           ; some examples/ use the zlib licence
 
+(define-public alembic
+  (package
+    (name "alembic")
+    (version "1.8.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alembic/alembic")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0glfx3cm7r8zn3cn7j4x4ch1ab6igfis0i2lcy23jc56q87r8yj2"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags (list "-DUSE_HDF5=ON")))
+    (inputs
+     (list hdf5 imath zlib))
+    (home-page "http://www.alembic.io/")
+    (synopsis "Framework for storing and sharing scene data")
+    (description "Alembic is a computer graphics interchange framework.  It
+distills complex, animated scenes into a set of baked geometric results.")
+    (license license:bsd-3)))
+
 (define-public ogre
   (package
     (name "ogre")