summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2018-07-05 14:18:42 +0300
committerAlex Kost <alezost@gmail.com>2018-07-09 19:26:05 +0300
commitfc4f13bde8483ae0542902633a6fea659e04e2ff (patch)
tree7ec04de6906b1449ede82f3dd5433e43ed272668 /gnu/packages/graphics.scm
parente311ef4f87f7ad8db2114e5f89961eea0240893b (diff)
downloadguix-fc4f13bde8483ae0542902633a6fea659e04e2ff.tar.gz
gnu: openscenegraph: Update to 3.6.2.
* gnu/packages/graphics.scm (openscenegraph): Update to 3.6.2.
[source]: Use the new url and 'git-fetch' method.
[properties]: Add 'upstream-name'.
[native-inputs]: Add 'pkg-config'.
[inputs]: Add 'libxrandr'.
* gnu/packages/patches/openscenegraph-ffmpeg3.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fffe972659..65f023a488 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2018 Alex Kost <alezost@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -408,17 +409,19 @@ visual effects work for film.")
 (define-public openscenegraph
   (package
     (name "openscenegraph")
-    (version "3.4.0")
+    (version "3.6.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://trac.openscenegraph.org/downloads/developer_releases/"
-                           "OpenSceneGraph-" version ".zip"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openscenegraph/OpenSceneGraph")
+             (commit (string-append "OpenSceneGraph-" version))))
        (sha256
         (base32
-         "03h4wfqqk7rf3mpz0sa99gy715cwpala7964z2npd8jxfn27swjw"))
-       (patches (search-patches "openscenegraph-ffmpeg3.patch"))
-       (file-name (string-append name "-" version ".zip"))))
+         "03jk6lclyd4biniaw04w7j0z1spkm69f1c19i37b8v9x3zv1p1id"))
+       (file-name (string-append name "-" version "-checkout"))))
+    (properties
+     `((upstream-name . "OpenSceneGraph")))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ; no test target available
@@ -430,11 +433,13 @@ visual effects work for film.")
                             (assoc-ref %outputs "out") "/lib:"
                             (assoc-ref %outputs "out") "/lib64"))))
     (native-inputs
-     `(("unzip" ,unzip)))
+     `(("pkg-config" ,pkg-config)
+       ("unzip" ,unzip)))
     (inputs
      `(("giflib" ,giflib)
        ("jasper" ,jasper)
        ("librsvg" ,librsvg)
+       ("libxrandr" ,libxrandr)
        ("pth" ,pth)
        ("qtbase" ,qtbase)
        ("ffmpeg" ,ffmpeg)