summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 12:23:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 16:37:28 +0100
commit3def739da13a166769777d0db7baba79230f64ae (patch)
tree32971aa5389fcdf8fe4de53790bd14e3a63aeffb /gnu/packages/graphics.scm
parentc695fb769c94623371c5997da1dc454b0a4f58a8 (diff)
downloadguix-3def739da13a166769777d0db7baba79230f64ae.tar.gz
gnu: Use the CMake build system's #:build-type key.
* gnu/packages/code.scm (rtags)[arguments]: Move the CMAKE_BUILD_TYPE
from #:configure-flags to #:build-type.
* gnu/packages/databases.scm (apache-arrow)[arguments]: Likewise
* gnu/packages/engineering.scm (kicad)[arguments]: Likewise
* gnu/packages/flashing-tools.scm (heimdall)[arguments]: Likewise
* gnu/packages/graphics.scm (openscenegraph)[arguments]: Likewise
* gnu/packages/linux.scm (rdma-core)[arguments]: Likewise
* gnu/packages/music.scm (portmidi)[arguments]: Likewise
* gnu/packages/photo.scm (rawtherapee)[arguments]: Likewise
* gnu/packages/rdesktop.scm (freerdp)[arguments]: Likewise
* gnu/packages/serialization.scm (flatbuffers)[arguments]: Likewise
* gnu/packages/web.scm (tidy-html)[arguments]: Likewise
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8ea9c74cec..d2f1b3b0b8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -423,15 +423,14 @@ visual effects work for film.")
        (file-name (string-append name "-" version ".zip"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ;; No test target available.
+     `(#:tests? #f ; no test target available
+       ;; Without this flag, 'rd' will be added to the name of the
+       ;; library binaries and break linking with other programs.
+       #:build-type "Release"
        #:configure-flags
        (list (string-append "-DCMAKE_INSTALL_RPATH="
                             (assoc-ref %outputs "out") "/lib:"
-                            (assoc-ref %outputs "out") "/lib64")
-             ;; We need to set this flag or otherwise 'rd' will be added
-             ;; to the name of the library binaries and break linking
-             ;; with other programs.
-             "-DCMAKE_BUILD_TYPE=Release")))
+                            (assoc-ref %outputs "out") "/lib64"))))
     (native-inputs
      `(("unzip" ,unzip)))
     (inputs