summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-08 23:51:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-08 23:54:32 -0400
commitd6fcc67de59ab5406348bf4fc206c9be82858f06 (patch)
tree7231a73e14bedaa26a97cec98fcbac84288d6211 /gnu/packages/graphics.scm
parentcb97d076491495aa956dbff93679a51cc5708010 (diff)
downloadguix-d6fcc67de59ab5406348bf4fc206c9be82858f06.tar.gz
gnu: lib2geom: Update to commit 17e0d21f.
* gnu/packages/patches/lib2geom-enable-assertions.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Unregister it.
* gnu/packages/graphics.scm (lib2geom): Update to commit
17e0d21f0afc8489656f9184bff7ad024a42394a, and remove obsolete patch.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cdb13c2619..91ac62e903 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -486,8 +486,8 @@ exception-handling library.")
 
 (define-public lib2geom
   ;; Use the latest master commit, as the 1.0 release suffer build problems.
-  (let ((revision "2")
-        (commit "f98256d2a923955af74b8cff3d456f0df1ee4b59"))
+  (let ((revision "3")
+        (commit "17e0d21f0afc8489656f9184bff7ad024a42394a"))
     (package
       (name "lib2geom")
       (version (git-version "1.0" revision commit))
@@ -499,13 +499,11 @@ exception-handling library.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0w6ijaai8i80d0f35c0shgdspqlsdhw3cvz106k1gm7bmnz1wzpq"))
+                  "0waskrmdrrdjw8pr5cvlkrxywgf376viggpc2jzdqxxpy2k78fpr"))
                 (patches
-                 ;; Patches submitted to upstream (see:
-                 ;; https://gitlab.com/inkscape/lib2geom/merge_requests/17,
+                 ;; Patch submitted to upstream (see:
                  ;; https://gitlab.com/inkscape/lib2geom/-/merge_requests/32).
-                 (search-patches "lib2geom-enable-assertions.patch"
-                                 "lib2geom-fix-tests.patch"))
+                 (search-patches "lib2geom-fix-tests.patch"))
                 (modules '((guix build utils)))
                 (snippet
                  '(begin