summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:11:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:08 +0200
commitea173bd87414f72ce61c0436b9503bef7f1beb45 (patch)
tree02072c212ae41a3a1e0e872cfc7cfdf847d6a950 /gnu/packages/graphics.scm
parentaae82f2a9587bf5c9f0af21be26e38e3bd941a84 (diff)
downloadguix-ea173bd87414f72ce61c0436b9503bef7f1beb45.tar.gz
gnu: Remove openscenegraph-3.4.
* gnu/packages/graphics.scm (openscenegraph-3.4): Remove variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 402a7406a7..aa026c60e3 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1284,32 +1284,6 @@ virtual reality, scientific visualization and modeling.")
     ;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
     (license license:lgpl2.1)))
 
-;; We need this for simgear
-(define-public openscenegraph-3.4
-  (package (inherit openscenegraph)
-    (name "openscenegraph")
-    (version "3.4.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/openscenegraph/OpenSceneGraph")
-             (commit (string-append "OpenSceneGraph-" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1fbzg1ihjpxk6smlq80p3h3ggllbr16ihd2fxpfwzam8yr8yxip9"))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments openscenegraph)
-       ((#:configure-flags flags)
-        `(cons
-          ;; The jpeg plugin requires conversion between integers and booleans
-          "-DCMAKE_CXX_FLAGS=-fpermissive"
-          ,flags))))
-    (inputs
-     `(("libjpeg" ,libjpeg-turbo)
-       ,@(package-inputs openscenegraph)))))
-
 (define-public gr-framework
   (package
     (name "gr-framework")