summary refs log tree commit diff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:34:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:30 -0400
commit454987fcb215b1c0a9cc971f3d28debb2f352f63 (patch)
tree8bf0cf269bd6f98be76c8b051f52a03682446d84 /gnu/packages/graphviz.scm
parent98b0ac0a77f9b72f58d5280776cbcce031e807aa (diff)
downloadguix-454987fcb215b1c0a9cc971f3d28debb2f352f63.tar.gz
gnu: dot2tex: Update to 2.11.3.
* gnu/packages/graphviz.scm (dot2tex): Update to 2.11.3.
[arguments]: Remove python argument.
[phases]: New argument.
[native-inputs]: New field.
[inputs]: Move texlive-latex-preview to...
[propagated-inputs]: ... here.  Replace python2-pyparsing with
python-parsing.  Add texlive-bin, texlive-amsmath, texlive-latex-geometry,
texlive-latex-graphics, texlive-latex-base, texlive-latex-xkeyval,
texlive-pgf, texlive-pstricks and  texlive-xcolor.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm30
1 files changed, 26 insertions, 4 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 2a99c0988e..f2fd90e616 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -415,11 +415,33 @@ graphs in Graphviz's DOT language, written in pure Python.")
                 "1kp77wiv7b5qib82i3y3sn9r49rym43aaqm5aw1bwnzfbbq2m6i9"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2))
-    (inputs
-     (list texlive-latex-preview graphviz))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv" "tests"
+                        ;; The test_semicolon test fails for unknown reason
+                        ;; (see:
+                        ;; https://github.com/kjellmf/dot2tex/issues/94).
+                        "-k" "not test_semicolon")))))))
+    (native-inputs (list python-pytest))
+    (inputs (list graphviz))
     (propagated-inputs
-     (list python2-pyparsing))
+     (list python-pyparsing
+           ;; These TeX dependencies are propagated to make it easier to build
+           ;; the resulting generated TeX files, which \usepackage them.
+           texlive-bin
+           texlive-amsmath
+           texlive-latex-geometry
+           texlive-latex-graphics
+           texlive-latex-base
+           texlive-latex-preview
+           texlive-latex-xkeyval
+           texlive-pgf
+           texlive-pstricks
+           texlive-xcolor))
     (home-page "https://github.com/kjellmf/dot2tex")
     (synopsis "Graphviz to LaTeX converter")
     (description