summary refs log tree commit diff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-07-12 19:55:55 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-07-14 15:39:26 +0530
commitcca9c756613201baec6655b4d7376727179e9951 (patch)
tree5506bf3957bebcb2330a8f47ffe4d8ba31869f06 /gnu/packages/graphviz.scm
parent2170cc76d4b2c47ccb831a706e8f40669c156e60 (diff)
downloadguix-cca9c756613201baec6655b4d7376727179e9951.tar.gz
gnu: graphviz: Update to 2.40.1.
* gnu/packages/graphviz.scm (graphviz): Update to 2.40.1.
[arguments]: Remove pre-build phase.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index d11160cbb1..6724ba6d7d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -44,7 +44,7 @@
 (define-public graphviz
   (package
     (name "graphviz")
-    (version "2.38.0")
+    (version "2.40.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -52,21 +52,13 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "17l5czpvv5ilmg17frg0w4qwf89jzh2aglm9fgx0l0aakn6j7al1"))))
+                "08d4ygkxz2f553bxj6087da56a23kx1khv0j8ycxa102vvx1hlna"))))
     (build-system gnu-build-system)
     (arguments
      ;; FIXME: rtest/rtest.sh is a ksh script (!).  Add ksh as an input.
      '(#:tests? #f
        #:phases
        (modify-phases %standard-phases
-         (add-before 'build 'pre-build
-           (lambda _
-             ;; Work around bogus makefile when using an external
-             ;; libltdl.  Failing to do so, one hits this error:
-             ;; "No rule to make target `-lltdl', needed by `libgvc.la'."
-             (substitute* "lib/gvc/Makefile"
-               (("am__append_5 *=.*")
-                "am_append_5 =\n"))))
          (add-after 'install 'move-docs
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))