summary refs log tree commit diff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-15 09:41:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-15 09:41:37 +0300
commitaf4c633bbb96e6c5311248970efbab5f98790900 (patch)
tree0974ffa3620b8714e4f48b9c1e6e3e00ac8e2d41 /gnu/packages/groff.scm
parent8aea855ac1fe05fc462206adb607d639a06b50a5 (diff)
downloadguix-af4c633bbb96e6c5311248970efbab5f98790900.tar.gz
gnu: roffit: Adjust install phase.
* gnu/packages/groff.scm (roffit)[arguments]: Remove make-flags. Remove
custom 'pre-install phase. Replace 'install phase to also install
manpage.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 0daf614302..0803a2a7f5 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -191,17 +191,15 @@ is usually the formatter of \"man\" documentation pages.")
       (build-system gnu-build-system)
       (arguments
        `(#:test-target "test"
-         #:make-flags
-         (list (string-append "INSTALLDIR="
-                              (assoc-ref %outputs "out") "/bin"))
          #:phases
          (modify-phases %standard-phases
            (delete 'configure)
-           (add-before 'install 'pre-install
+           (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
-               (mkdir-p (string-append (assoc-ref outputs "out")
-                                       "/bin"))
-               #t))
+               (let ((out (assoc-ref outputs "out")))
+                 (install-file "roffit" (string-append out "/bin"))
+                 (install-file "roffit.1" (string-append out "/share/man/man1"))
+                 #t)))
            (add-after 'install 'wrap-program
              (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out")))