summary refs log tree commit diff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-08-29 07:58:36 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-08-31 15:05:10 +0200
commite9e6d40b2292c4a3fbc86bee6a7146eaba59c075 (patch)
tree14921da1e91532f506eccc7ce5798ab9edbd6d19 /gnu/packages/groff.scm
parentbed19695244f46cd3b16ef974573efcb5f8326a5 (diff)
downloadguix-e9e6d40b2292c4a3fbc86bee6a7146eaba59c075.tar.gz
gnu: groff: Make build reproducible.
* gnu/packages/groff.scm (groff)[arguments]: Add phase "setenv".
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 67dd1dbfa6..6e1a60e9ba 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -56,7 +56,14 @@
                     ("perl" ,perl)
                     ("psutils" ,psutils)
                     ("texinfo" ,texinfo)))
-   (arguments '(#:parallel-build? #f))  ; parallel build fails
+   (arguments
+    `(#:parallel-build? #f   ; parallel build fails
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'setenv
+          (lambda _
+            (setenv "GS_GENERATE_UUIDS" "0")
+            #t)))))
    (synopsis "Typesetting from plain text mixed with formatting commands")
    (description
     "Groff is a typesetting package that reads plain text and produces