summary refs log tree commit diff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-13 20:31:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:36:06 +0200
commitfdc9170bc1d9a57aa9a542c307b15b5b965d2f4b (patch)
tree024cc9c50fa77af45afa051e68421da07e3ef75f /gnu/packages/groovy.scm
parent27ba9760e04019cc3ed3457199194088f4b45486 (diff)
downloadguix-fdc9170bc1d9a57aa9a542c307b15b5b965d2f4b.tar.gz
gnu: Add java-groovy-bootstrap.
* gnu/packages/groovy.scm: New file.
* gnu/packages/patches/groovy-add-exceptionutilsgenerator.patch: New
file.
* gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm97
1 files changed, 97 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
new file mode 100644
index 0000000000..d7409f4481
--- /dev/null
+++ b/gnu/packages/groovy.scm
@@ -0,0 +1,97 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages groovy)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system ant)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages java)
+  #:use-module (gnu packages xml))
+
+(define java-groovy-bootstrap
+  (package
+    (name "groovy-java-bootstrap")
+    (version "2.4.15")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/apache/groovy/archive/GROOVY_"
+                                  (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
+                                  ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19f3yd2z6jmz1xhwi5kkg1wmgbqkfs7qvd3rzb43xr3nffz8cisv"))
+              (patches
+                (search-patches
+                  "groovy-add-exceptionutilsgenerator.patch"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "groovy.jar"
+       #:source-dir "src/main:subprojects/groovy-test/src/main/java"
+       #:test-dir "src/test"
+       #:tests? #f
+       #:jdk ,icedtea-8
+       #:main-class "groovy.ui.GroovyMain"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'fix-java8
+           ;; Fix "Reference to plus is ambiguous"
+           (lambda _
+             (substitute* "src/main/org/codehaus/groovy/runtime/DefaultGroovyMethods.java"
+               (("toList\\(left\\)")
+                "(List<T>)toList(left)"))
+             #t))
+         (add-before 'build 'generate-parsers
+           (lambda _
+             (with-directory-excursion "src/main/org/codehaus/groovy/antlr/java"
+               (invoke "antlr" "java.g"))
+             (with-directory-excursion "src/main/org/codehaus/groovy/antlr"
+               (mkdir "parser")
+               (with-directory-excursion "parser"
+                 (invoke "antlr" "../groovy.g")))
+             #t))
+         (add-before 'build 'generate-exception-utils
+           (lambda _
+             (invoke "javac" "-cp" (getenv "CLASSPATH")
+                     "config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java")
+             (invoke "java" "-cp" (string-append (getenv "CLASSPATH")
+                                                 ":config/ant/src")
+                     "org.codehaus.groovy.ExceptionUtilsGenerator"
+                     "build/classes/org/codehaus/groovy/runtime/ExceptionUtils.class")
+             #t)))))
+    (native-inputs
+     `(("java-junit" ,java-junit)
+       ("java-hamcrest-core" ,java-hamcrest-core)
+       ("antlr2" ,antlr2)
+       ("java-jmock-1" ,java-jmock-1)
+       ("java-xmlunit-legacy" ,java-xmlunit-legacy)))
+    (inputs
+     `(("java-commons-cli" ,java-commons-cli)
+       ("java-asm" ,java-asm)
+       ("java-classpathx-servletapi" ,java-classpathx-servletapi)
+       ("java-xstream" ,java-xstream)
+       ("java-jansi" ,java-jansi)
+       ("java-jline-2" ,java-jline-2)))
+    (home-page "http://groovy-lang.org/")
+    (synopsis "Groovy's java bootstrap")
+    (description "This package contains the java bootstrap that is used to build
+groovy submodules.")
+    (license license:asl2.0)))