summary refs log tree commit diff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 14:25:16 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:36:42 +0200
commite0e4bae20b9bcd7fc4bb188526a8a8fc369f6cb3 (patch)
tree75a491bd379c8514ebe50a359b10cd39bff7d796 /gnu/packages/groovy.scm
parent6f07785299265fc8e920ca59cdfe6637dd588281 (diff)
downloadguix-e0e4bae20b9bcd7fc4bb188526a8a8fc369f6cb3.tar.gz
gnu: Add groovy-xml.
* gnu/packages/groovy.scm (groovy-xml): New variable.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index e4ee77b5c4..6d535f6a1c 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -253,3 +253,49 @@ other groovy submodules.")))
     (synopsis "Groovy test submodule")
     (description "This package contains the test submodules used to test
 other groovy submodules.")))
+
+(define groovy-xml
+  (package
+    (inherit groovy-bootstrap)
+    (name "groovy-xml")
+    (arguments
+     `(#:jar-name "groovy-xml.jar"
+       #:jdk ,icedtea-8
+       #:test-dir "src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'chdir
+           (lambda _
+             (chdir "subprojects/groovy-xml")
+             #t))
+         (replace 'build
+           (lambda _
+             (mkdir-p "build/classes")
+             (mkdir-p "build/jar")
+             (apply invoke "java" "-cp" (getenv "CLASSPATH")
+                    "org.codehaus.groovy.tools.FileSystemCompiler"
+                    "-d" "build/classes" "-j"; joint compilation
+                    (find-files "src/main" ".*\\.(groovy|java)$"))
+             (invoke "jar" "-cf" "build/jar/groovy-xml.jar"
+                     "-C" "build/classes" ".")
+             #t))
+         (replace 'check
+           (lambda _
+             (mkdir-p "build/test-classes")
+             (substitute* "build.xml"
+               (("depends=\"compile-tests\"") "depends=\"\"")
+               (("}/java") "}/groovy"))
+             (apply invoke "java" "-cp"
+                    (string-append (getenv "CLASSPATH") ":build/classes")
+                    "org.codehaus.groovy.tools.FileSystemCompiler"
+                    "-d" "build/test-classes" "-j"
+                    (append (find-files "src/test" ".*\\.(groovy|java)$")))
+             (invoke "ant" "check")
+             #t)))))
+    (native-inputs
+     `(("groovy-bootstrap" ,groovy-bootstrap)
+       ("groovy-test" ,groovy-test)
+       ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+       ,@(package-native-inputs java-groovy-bootstrap)))
+    (synopsis "Groovy XML")
+    (description "This package contains XML-related utilities for groovy.")))