summary refs log tree commit diff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 15:13:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:39 +0100
commitef6a5fcc30dd56fa8ef7a4be53b98a736499b833 (patch)
tree2a9a22644765fe680057f3962d64217ea77a286b /gnu/packages/groovy.scm
parent3047c7baae84271080336936e12c89bad5c3559f (diff)
downloadguix-ef6a5fcc30dd56fa8ef7a4be53b98a736499b833.tar.gz
gnu: java-groovy-bootstrap: Don't use unstable tarball.
* gnu/packages/groovy.scm (java-groovy-bootstrap)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index aaa524b1ba..f5d0416f36 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Tobias Geerinck-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,6 +21,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system ant)
   #:use-module (gnu packages)
@@ -30,18 +32,20 @@
   (package
     (name "java-groovy-bootstrap")
     (version "2.4.15")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/apache/groovy/archive/GROOVY_"
-                                  (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
-                                  ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "19f3yd2z6jmz1xhwi5kkg1wmgbqkfs7qvd3rzb43xr3nffz8cisv"))
-              (patches
-                (search-patches
-                  "groovy-add-exceptionutilsgenerator.patch"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/apache/groovy.git")
+             (commit (string-append
+                      "GROOVY_"
+                      (string-map (lambda (x) (if (eq? x #\.) #\_ x))
+                                  version)))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1q4cplimr18j93zz92kgq8b6wdv0p9svr7cdr47q8b2mbjpd0x3j"))
+       (patches
+        (search-patches "groovy-add-exceptionutilsgenerator.patch"))))
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "groovy.jar"