summary refs log tree commit diff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-19 18:18:43 -0500
committerLeo Famulari <leo@famulari.name>2015-12-21 12:33:55 -0500
commitf0150f8724f09fa650a0cbb66d3ef5a8a99804c4 (patch)
tree44d2541c13b90e85120928a6e87ea2f6e0c40510 /gnu/packages/grub.scm
parente2cd1d0fb918b55a1ab16271fac758b260057030 (diff)
downloadguix-f0150f8724f09fa650a0cbb66d3ef5a8a99804c4.tar.gz
gnu: grub: Add fix for CVE-2015-8730.
* gnu/packages/patches/grub-CVE-2015-8370.patch: New file.
* gnu-system.am (dist_patch_DATA): Register patch.
* gnu/packages/grub.scm: Apply patch.
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 79fc2f0aca..96d284c108 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -83,7 +84,8 @@
               (base32
                "0n64hpmsccvicagvr0c6v0kgp2yw0kgnd3jvsyd26cnwgs7c6kkq"))
              (patches (list (search-patch "grub-gets-undeclared.patch")
-                            (search-patch "grub-freetype.patch")))))
+                            (search-patch "grub-freetype.patch")
+                            (search-patch "grub-CVE-2015-8370.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--disable-werror")