summary refs log tree commit diff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-02-09 19:46:47 +0100
committerDavid Craven <david@craven.ch>2017-02-10 17:15:35 +0100
commit862e38d551801426e2f4953d13588d504d21381b (patch)
treefc1423ab69109d839666128dcbfc2e04bcd5f8f6 /gnu/packages/grub.scm
parent96b714f5fdfadfa93865fe3151233b0b5beec1c1 (diff)
downloadguix-862e38d551801426e2f4953d13588d504d21381b.tar.gz
gnu: Move (gnu packages grub) and (gnu packages u-boot) ...
     to (gnu packages bootloaders).

* gnu/packages/grub.scm: Rename to bootloaders.scm.
* gnu/packages/u-boot.scm: Move to bootloaders.scm.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add bootloaders.scm,
  remove grub.scm and u-boot.scm;
* gnu/system/grub.scm: Import (gnu packages bootloaders).
* gnu/system/install.scm: Import (gnu packages bootloaders).
* gnu/system/vm.scm: Import (gnu packages bootloaders).
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm215
1 files changed, 0 insertions, 215 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
deleted file mode 100644
index 4d9dc819b7..0000000000
--- a/gnu/packages/grub.scm
+++ /dev/null
@@ -1,215 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages grub)
-  #:use-module (guix download)
-  #:use-module (guix packages)
-  #:use-module (guix utils)
-  #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (guix build-system gnu)
-  #:use-module (gnu packages)
-  #:use-module (gnu packages flex)
-  #:use-module (gnu packages disk)
-  #:use-module (gnu packages bison)
-  #:use-module (gnu packages gettext)
-  #:use-module (gnu packages fontutils)
-  #:use-module (gnu packages linux)
-  #:use-module (gnu packages perl)
-  #:use-module (gnu packages python)
-  #:use-module (gnu packages qemu)
-  #:use-module (gnu packages man)
-  #:use-module (gnu packages texinfo)
-  #:use-module (gnu packages ncurses)
-  #:use-module (gnu packages cdrom))
-
-(define unifont
-  ;; GNU Unifont, <http://gnu.org/s/unifont>.
-  ;; GRUB needs it for its graphical terminal, gfxterm.
-  (origin
-    (method url-fetch)
-    (uri
-     "http://unifoundry.com/pub/unifont-7.0.06/font-builds/unifont-7.0.06.bdf.gz")
-    (sha256
-     (base32
-      "0p2vhnc18cnbmb39vq4m7hzv4mhnm2l0a2s7gx3ar277fwng3hys"))))
-
-(define-public grub
-  (package
-    (name "grub")
-    (version "2.02rc1")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "ftp://alpha.gnu.org/gnu/grub/grub-"
-                   "2.02~rc1"
-                   ".tar.xz"))
-             (file-name (string-append name "-" version ".tar.xz"))
-             (sha256
-              (base32
-               "0y02v19x9sb5jvj740f604vvi5j1rx8pily1jk0l64bdp7lkjlj4"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'patch-stuff
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     (substitute* "grub-core/Makefile.in"
-                       (("/bin/sh") (which "sh")))
-
-                     ;; Give the absolute file name of 'mdadm', used to
-                     ;; determine the root file system when it's a RAID
-                     ;; device.  Failing to do that, 'grub-probe' silently
-                     ;; fails if 'mdadm' is not in $PATH.
-                     (substitute* "grub-core/osdep/linux/getroot.c"
-                       (("argv\\[0\\] = \"mdadm\"")
-                        (string-append "argv[0] = \""
-                                       (assoc-ref inputs "mdadm")
-                                       "/sbin/mdadm\"")))
-
-                     ;; Make the font visible.
-                     (copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
-                     (system* "gunzip" "unifont.bdf.gz")
-                     #t)))))
-    (inputs
-     `(("gettext" ,gettext-minimal)
-
-       ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
-       ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
-       ("lvm2" ,lvm2)
-
-       ;; Depend on mdadm, which is invoked by 'grub-probe' and 'grub-install'
-       ;; to determine whether the root file system is RAID.
-       ("mdadm" ,mdadm)
-
-       ("freetype" ,freetype)
-       ;; ("libusb" ,libusb)
-       ;; ("fuse" ,fuse)
-       ("ncurses" ,ncurses)))
-    (native-inputs
-     `(("unifont" ,unifont)
-       ("bison" ,bison)
-       ("flex" ,flex)
-       ("texinfo" ,texinfo)
-       ("help2man" ,help2man)
-
-       ;; Dependencies for the test suite.  The "real" QEMU is needed here,
-       ;; because several targets are used.
-       ("parted" ,parted)
-       ("qemu" ,qemu-minimal)
-       ("xorriso" ,xorriso)))
-    (home-page "https://www.gnu.org/software/grub/")
-    (synopsis "GRand Unified Boot loader")
-    (description
-     "GRUB is a multiboot bootloader.  It is used for initially loading the
-kernel of an operating system and then transferring control to it.  The kernel
-then goes on to load the rest of the operating system.  As a multiboot
-bootloader, GRUB handles the presence of multiple operating systems installed
-on the same computer; upon booting the computer, the user is presented with a
-menu to select one of the installed operating systems.")
-    (license license:gpl3+)
-    (properties '((cpe-name . "grub2")))))
-
-(define-public grub-efi
-  (package
-    (inherit grub)
-    (name "grub-efi")
-    (synopsis "GRand Unified Boot loader (UEFI version)")
-    (inputs
-     `(("efibootmgr" ,efibootmgr)
-       ,@(package-inputs grub)))
-    (arguments
-     `(;; TODO: Tests need a UEFI firmware for qemu. There is one at
-       ;; https://github.com/tianocore/edk2/tree/master/OvmfPkg .
-       ;; Search for 'OVMF' in "tests/util/grub-shell.in".
-       #:tests? #f
-       ,@(substitute-keyword-arguments (package-arguments grub)
-           ((#:configure-flags flags ''())
-            `(cons "--with-platform=efi" ,flags))
-           ((#:phases phases)
-            `(modify-phases ,phases
-               (add-after 'patch-stuff 'use-absolute-efibootmgr-path
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (substitute* "grub-core/osdep/unix/platform.c"
-                     (("efibootmgr")
-                      (string-append (assoc-ref inputs "efibootmgr")
-                                     "/sbin/efibootmgr")))
-                   #t)))))))))
-
-(define-public syslinux
-  (let ((commit "bb41e935cc83c6242de24d2271e067d76af3585c"))
-    (package
-      (name "syslinux")
-      (version (git-version "6.04-pre" "1" commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/geneC/syslinux")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0k8dvafd6410kqxf3kyr4y8jzmpmrih6wbjqg6gklak7945yflrc"))))
-      (build-system gnu-build-system)
-      (native-inputs
-       `(("nasm" ,nasm)
-         ("perl" ,perl)
-         ("python-2" ,python-2)))
-      (inputs
-       `(("libuuid" ,util-linux)))
-      (arguments
-       `(#:parallel-build? #f
-         #:make-flags
-         (list (string-append "BINDIR=" %output "/bin")
-               (string-append "SBINDIR=" %output "/sbin")
-               (string-append "LIBDIR=" %output "/lib")
-               (string-append "INCDIR=" %output "/include")
-               (string-append "DATADIR=" %output "/share")
-               (string-append "MANDIR=" %output "/share/man")
-               "PERL=perl"
-               "bios")
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-files
-             (lambda _
-               (substitute* (find-files "." "Makefile.*|ppmtolss16")
-                 (("/bin/pwd") (which "pwd"))
-                 (("/bin/echo") (which "echo"))
-                 (("/usr/bin/perl") (which "perl")))
-               #t))
-           (delete 'configure)
-           (add-before 'build 'set-permissions
-             (lambda _
-               (zero? (system* "chmod" "a+w" "utils/isohybrid.in"))))
-           (replace 'check
-             (lambda _
-               (setenv "CC" "gcc")
-               (substitute* "tests/unittest/include/unittest/unittest.h"
-                 ;; Don't look up headers under /usr.
-                 (("/usr/include/") ""))
-               (zero? (system* "make" "unittest")))))))
-      (home-page "http://www.syslinux.org")
-      (synopsis "Lightweight Linux bootloader")
-      (description "Syslinux is a lightweight Linux bootloader.")
-      (license (list license:gpl2+
-                     license:bsd-3 ; gnu-efi/*
-                     license:bsd-4 ; gnu-efi/inc/* gnu-efi/lib/*
-                     ;; Also contains:
-                     license:expat license:isc license:zlib)))))