summary refs log tree commit diff
path: root/gnu/packages/gsasl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-04 17:02:07 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-04 17:23:27 +0100
commitf61e0e79006f1192c33622c4d564e95391763224 (patch)
tree210fa85de8be6d346327c302425cdf6905929daa /gnu/packages/gsasl.scm
parent6d0b9d03ced244093c026b3433ec06643d78236c (diff)
downloadguix-f61e0e79006f1192c33622c4d564e95391763224.tar.gz
gnu: Avoid #:prefix when importing a (gnu packages …) module.
* gnu/packages/admin.scm, gnu/packages/emacs.scm,
  gnu/packages/gnutls.scm, gnu/packages/gsasl.scm,
  gnu/packages/linux.scm: Remove uses of #:prefix for package modules.
Diffstat (limited to 'gnu/packages/gsasl.scm')
-rw-r--r--gnu/packages/gsasl.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/gsasl.scm b/gnu/packages/gsasl.scm
index 071ffb4b84..d5de2f2ee8 100644
--- a/gnu/packages/gsasl.scm
+++ b/gnu/packages/gsasl.scm
@@ -18,12 +18,12 @@
 
 (define-module (gnu packages gsasl)
   #:use-module (gnu packages)
-  #:use-module ((gnu packages compression) #:prefix guix:)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages gnutls)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages shishi)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
@@ -42,7 +42,7 @@
    (synopsis "Library that implements NTLM authentication")
    (description
     "Libntlm is a library that implements NTLM authentication")
-   (license lgpl2.1+)
+   (license license:lgpl2.1+)
    (home-page "http://www.nongnu.org/libntlm/")))
 
 (define-public gss
@@ -58,8 +58,7 @@
    (build-system gnu-build-system)
    (inputs `(("nettle" ,nettle)
              ("shishi" ,shishi)
-             ("zlib" ,guix:zlib)
-            ))
+             ("zlib" ,zlib)))
    (synopsis "Generic Security Service library")
    (description
     "The GNU Generic Security Service provides a free implementation of the
@@ -68,7 +67,7 @@ interface for programs to access security services.  Security services present
 a generic, GSS interface, with which the calling application interacts via
 this library, freeing the application developer from needing to know about
 the underlying security implementation.")
-   (license gpl3+)
+   (license license:gpl3+)
    (home-page "http://www.gnu.org/software/gss/")))
 
 (define-public gsasl
@@ -85,7 +84,7 @@ the underlying security implementation.")
    (inputs `(("libidn" ,libidn)
              ("libntlm" ,libntlm)
              ("gss" ,gss)
-             ("zlib" ,guix:zlib)))
+             ("zlib" ,zlib)))
    (propagated-inputs
     ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
     ;; propagated input of GnuTLS.
@@ -96,5 +95,5 @@ the underlying security implementation.")
 Security Layer framework.  On network servers such as IMAP or SMTP servers,
 SASL is used to handle client/server authentication.  This package contains
 both a library and a command-line tool to access the library.")
-   (license gpl3+)
+   (license license:gpl3+)
    (home-page "http://www.gnu.org/software/gsasl/")))