summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-26 19:23:19 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-28 20:30:43 +0200
commit9c02f19d6de8a09b90f3bca7c0eba5dd86f4edc0 (patch)
tree1d42a6ba1dc6c3edaf7c1df818c7eef401faca62 /gnu/packages/gstreamer.scm
parentf1e8cc6a9826f951fe95dc374b4db6fc8e25d981 (diff)
downloadguix-9c02f19d6de8a09b90f3bca7c0eba5dd86f4edc0.tar.gz
gnu: gst-plugins-good: Update to 1.20.3.
* gnu/packages/gstreamer.scm (gst-plugins-good): Update to 1.20.3.
[source]<patches>: Remove “gst-plugins-good-fix-test.patch”.
[arguments]<#:phases>: Add ‘absolutize-libsoup-library’ and
‘skip-failing-tests’.
* gnu/packages/patches/gst-plugins-good-fix-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0f655db067..b781fa06e9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -608,7 +608,7 @@ for the GStreamer multimedia library.")
 (define-public gst-plugins-good
   (package
     (name "gst-plugins-good")
-    (version "1.18.5")
+    (version "1.20.3")
     (source
      (origin
        (method url-fetch)
@@ -616,15 +616,28 @@ for the GStreamer multimedia library.")
         (string-append
          "https://gstreamer.freedesktop.org/src/" name "/"
          name "-" version ".tar.xz"))
-       (patches (search-patches "gst-plugins-good-fix-test.patch"))
        (sha256
-        (base32 "0svrapawych2s3lm4lx3x023zxq5kcx50jnfmh0qigszfskyxbis"))))
+        (base32 "1dv8b2md1xk6d45ir1wzbvqhxbvm6mxv881rjl0brnjwpw3c5wzq"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases
        (modify-phases %standard-phases
          ,@%common-gstreamer-phases
+         (add-after 'unpack 'absolutize-libsoup-library
+           (lambda* (#:key inputs #:allow-other-keys)
+             (define libsoup
+               (search-input-file inputs "lib/libsoup-3.0.so"))
+
+             (substitute* "ext/soup/gstsouploader.c"
+               (("(#define LIBSOUP_3_SONAME ).+$" _ prefix)
+                (string-append prefix "\"" libsoup "\"\n")))))
+         (add-after 'unpack 'skip-failing-tests
+           (lambda _
+             (substitute* "tests/check/meson.build"
+               ;; Reported as shaky upstream, see
+               ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/785>
+               (("\\[ 'elements/flvmux' \\]") "[ 'elements/flvmux', true ]"))))
          (add-before 'check 'pre-check
            (lambda _
              ;; Tests require a running X server.