summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 22:13:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:55 -0400
commitf346327172051b28e78e66f0ea5fd07d5b9ba490 (patch)
tree0b86a5096c08915a1c4cb114a859d2eab0da92b2 /gnu/packages/gstreamer.scm
parent5f64f7abca4d59130616e87263b8a8c2a3769c3a (diff)
downloadguix-f346327172051b28e78e66f0ea5fd07d5b9ba490.tar.gz
gnu: gst-plugins-good: Skip the test_video_caps_late test.
* gnu/packages/gstreamer.scm (gst-plugins-good)
[arguments]: Skip the test_video_caps_late test in the skip-failing-tests
phase.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 38845b83af..a89233bbac 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -674,6 +674,11 @@ for the GStreamer multimedia library.")
                  (string-append prefix "\"" libsoup "\"\n")))))
           (add-after 'unpack 'skip-failing-tests
             (lambda _
+              (substitute* "tests/check/elements/flvmux.c"
+                ;; This test randomly times out (see:
+                ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/786).
+                ((".*tcase_add_test.*test_video_caps_late.*")
+                 ""))
               (substitute* "tests/check/meson.build"
                 ;; Reported as shaky upstream, see
                 ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/785>