summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-08-17 13:43:04 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 13:27:41 +0200
commit399c5fafcdb2d0c13ab51e4ab57d451d2c7cb1bd (patch)
tree87f46e1b37ce1afa1240ac887943e1969a1967fe /gnu/packages/gstreamer.scm
parent72e782b2b587d05e89b2ca9b27b30c93653760f5 (diff)
downloadguix-399c5fafcdb2d0c13ab51e4ab57d451d2c7cb1bd.tar.gz
gnu: gst-plugins-base: Don't build with Opus for 32-bit systems.
Fixes <https://bugs.gnu.org/32360> and <https://bugs.gnu.org/32466>.

* gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Exclude opus
when building for 32-bit systems.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 951ca93fbf..d26a4c425a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -167,7 +167,6 @@ This package provides the core library and elements.")
        ("orc" ,orc)))              ;required by gstreamer-audio-1.0.pc
     (inputs
      `(("cdparanoia" ,cdparanoia)
-       ("opus" ,opus)
        ("pango" ,pango)
        ("libogg" ,libogg)
        ("libtheora" ,libtheora)
@@ -176,7 +175,12 @@ This package provides the core library and elements.")
        ("zlib" ,zlib)
        ("libXext" ,libxext)
        ("libxv" ,libxv)
-       ("alsa-lib" ,alsa-lib)))
+       ("alsa-lib" ,alsa-lib)
+       ;; XXX Don't build with opus on 32-bit systems:
+       ;; <https://bugs.gnu.org/32360>
+       ,@(if (target-64bit?)
+             `(("opus" ,opus))
+             '())))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("glib:bin" ,glib "bin")