summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 21:44:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 23:18:49 +0100
commitc450ee975529f25607e67cb405a2a6b515cf655e (patch)
tree44a12b83d58acdc9f2dee9c88488af2c72fa7d2c /gnu/packages/gstreamer.scm
parent4bebd7e4e606c1fc7578c948094675e6f95c2619 (diff)
downloadguix-c450ee975529f25607e67cb405a2a6b515cf655e.tar.gz
gnu: python-gst: Build with Meson.
* gnu/packages/gstreamer.scm (python-gst)[build-system]: Change to MESON-BUILD-SYSTEM.
[arguments]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index d84d2009b5..6fd683c9de 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -447,15 +447,16 @@ compression formats through the use of the libav library.")
               (sha256
                (base32
                 "1a48ca66izmm8hnp608jv5isg3jxb0vlfmhns0bg9nbkilag7390"))))
-    (build-system gnu-build-system)
+    (build-system meson-build-system)
     (arguments
-     `(#:modules ((guix build gnu-build-system)
+     `(#:modules ((guix build meson-build-system)
+                  (guix build utils)
                   ((guix build python-build-system) #:prefix python:))
-       #:imported-modules (,@%gnu-build-system-modules
+       #:imported-modules (,@%meson-build-system-modules
                            (guix build python-build-system))
        #:configure-flags
        (list (string-append
-              "--with-pygi-overrides-dir="
+              "-Dpygi-overrides-dir="
               (python:site-packages %build-inputs %outputs) "gi/overrides"))))
     (native-inputs
      `(("pkg-config" ,pkg-config)