summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-09 17:15:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 20:58:15 +0100
commit037d59136763c03243e76ebe5d6e40bed6653333 (patch)
tree74520a13dffd1b4913ccafecee79cc9c545e93d0 /gnu/packages/gstreamer.scm
parent4a3436449b5ccfb8455c0023baaa0a1bf5fdab39 (diff)
downloadguix-037d59136763c03243e76ebe5d6e40bed6653333.tar.gz
gnu: libvpx: Update to 1.8.0.
* gnu/packages/patches/gst-plugins-good-libvpx-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/video.scm (libvpx): Update to 1.8.0.
[source](patches): Remove obsolete patch.
(libvpx-1.7): New public variable.
* gnu/packages/gnuzilla.scm (icecat)[inputs]: Use LIBVPX-1.7 instead of LIBVPX.
* gnu/packages/gstreamer.scm (gst-plugins-good)[source](patches): New field.
[arguments]: Add #:make-flags.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 755904231b..48a4dffa46 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -216,6 +216,7 @@ for the GStreamer multimedia library.")
       (uri (string-append
             "https://gstreamer.freedesktop.org/src/" name "/"
             name "-" version ".tar.xz"))
+      (patches (search-patches "gst-plugins-good-libvpx-compat.patch"))
       (sha256
        (base32
         "0y89qynb4b6fry3h43z1r99qslmi3m8xhlq0i5baq2nbc0r5b2sz"))))
@@ -249,7 +250,8 @@ for the GStreamer multimedia library.")
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
     (arguments
-     `(#:phases
+     `(#:make-flags '("CFLAGS=-DHAVE_VPX_1_8")   ;XXX: Remove for >1.14.
+       #:phases
        (modify-phases %standard-phases
          (add-after
           'unpack 'disable-failing-tests