summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 00:10:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:23 -0500
commit543367ae89d748499b2b4bf70a6ee0830f727e9a (patch)
treea5a2e24922de13d456ae5d31358cf4bfee8e2368 /gnu/packages/gstreamer.scm
parent95e99e3829a3ccd9c013c4852a50c5c3318b0580 (diff)
downloadguix-543367ae89d748499b2b4bf70a6ee0830f727e9a.tar.gz
gnu: gst-plugins-bad: Update to 1.19.2.
* gnu/packages/gstreamer.scm (gst-plugins-bad): Update to 1.19.2.
* gnu/packages/patches/gst-plugins-bad-fix-overflow.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a4c9ed5fb5..3b6fe05f78 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -702,15 +702,14 @@ model to base your own plug-in on, here it is.")
 (define-public gst-plugins-bad
   (package
     (name "gst-plugins-bad")
-    (version "1.18.4")
+    (version "1.19.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://gstreamer.freedesktop.org/src/"
                                   name "/" name "-" version ".tar.xz"))
-              (patches (search-patches "gst-plugins-bad-fix-overflow.patch"))
               (sha256
                (base32
-                "0py8k4pbalm9mxkpjbjxis0gp7g74wg5g4yax5q8rccmany0ds3l"))
+                "0y895s0jpfdpdqh2n55ki6gzvji5228v7z541if2xjgjka5gk0jk"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -719,6 +718,7 @@ model to base your own plug-in on, here it is.")
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags '("-Dsctp-internal-usrsctp=disabled")
+       #:meson ,meson-0.55
        #:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases
        (modify-phases %standard-phases
@@ -756,8 +756,7 @@ model to base your own plug-in on, here it is.")
                  ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
                  ((".*elements/curlhttpsrc\\.c.*") "")
                  ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412
-                 ((".*elements/dtls\\.c.*") ""))
-               #t)))
+                 ((".*elements/dtls\\.c.*") "")))))
          (add-before 'check 'pre-check
            (lambda _
              ;; Tests require a running X server.
@@ -768,8 +767,7 @@ model to base your own plug-in on, here it is.")
              ;; Tests look for $XDG_RUNTIME_DIR.
              (setenv "XDG_RUNTIME_DIR" (getcwd))
              ;; For missing '/etc/machine-id'.
-             (setenv "DBUS_FATAL_WARNINGS" "0")
-             #t)))))
+             (setenv "DBUS_FATAL_WARNINGS" "0"))))))
     (propagated-inputs
      `(("gstreamer" ,gstreamer)
        ("gst-plugins-base" ,gst-plugins-base)))