summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-27 16:13:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:23 -0500
commit86528cab04b16a4fbc3e81368b4cd405e85a4c8e (patch)
tree44d82f612260310fcfdca88b3d73e7a24a97accc /gnu/packages/gtk.scm
parent33c7e1834739da8905aecd09fa44c8744bf7d773 (diff)
downloadguix-86528cab04b16a4fbc3e81368b4cd405e85a4c8e.tar.gz
gnu: gdk-pixbuf: Remove obsolete jasper support.
The newer meson 0.60 failed the build because the jasper flag no longer
exists.

* gnu/packages/gtk.scm (gdk-pixbuf)[configure-flags]<jasper>: Remove configure
flag.
[phases]{patch-docbook}: Remove condition and TODO comment.
[inputs]: Remove jasper.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b199032f15..daeb445d5f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -638,16 +638,12 @@ highlighting and other features typical of a source code editor.")
     (build-system meson-build-system)
     (outputs '("out" "debug"))
     (arguments
-     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
-       #:configure-flags '("-Dinstalled_tests=false" "-Djasper=true")
+     `(#:glib-or-gtk? #t             ; To wrap binaries and/or compile schemas
+       #:configure-flags '("-Dinstalled_tests=false")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-docbook
-           ;; TODO(core-updates): Unconditionally look in (or native-inputs inputs)
-           (lambda* (#:key ,@(if (%current-target-system)
-                                 '(native-inputs)
-                                 '())
-                     inputs #:allow-other-keys)
+           (lambda* (#:key native-inputs inputs #:allow-other-keys)
              (with-directory-excursion "docs"
                (substitute* "meson.build"
                  (("http://docbook.sourceforge.net/release/xsl/current/")
@@ -684,7 +680,6 @@ highlighting and other features typical of a source code editor.")
      `(,@(if (%current-target-system)
              `(("bash-minimal" ,bash-minimal)) ; for glib-or-gtk-wrap
              '())
-       ("jasper" ,jasper)
        ("libjpeg" ,libjpeg-turbo)
        ("libpng"  ,libpng)
        ("libtiff" ,libtiff)))
@@ -692,7 +687,7 @@ highlighting and other features typical of a source code editor.")
      `(("docbook-xml" ,docbook-xml-4.3)
        ("docbook-xsl" ,docbook-xsl)
        ("gettext" ,gettext-minimal)
-       ("glib" ,glib "bin")             ; glib-mkenums, etc.
+       ("glib" ,glib "bin")                             ; glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)