summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-05-10 18:15:54 -0400
committerEfraim Flashner <efraim@flashner.co.il>2016-05-16 06:10:06 +0300
commit9c0c77f833b64e5ce46d1b53a4fbbd0b0cb1d0c2 (patch)
treea65d9c506d0fe3fa25ddf99d568e4a6fa0cfaa15 /gnu/packages/gtk.scm
parent5c6fdaa9e15a91485e4d5f8d43d2918ec2b42d94 (diff)
downloadguix-9c0c77f833b64e5ce46d1b53a4fbbd0b0cb1d0c2.tar.gz
gnu: Add gtkspell3.
* gnu/packages/gtk.scm (gtkspell3): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7e81a81986..8abf16ef36 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,6 +42,7 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages enchant)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
@@ -1244,3 +1246,30 @@ Redmond95 and ThinIce.")
      "Murrine is a cairo-based GTK+ theming engine.  It is named after the
 glass artworks done by Venicians glass blowers.")
     (license license:gpl2+)))
+
+(define-public gtkspell3
+  (package
+    (name "gtkspell3")
+    (version "3.0.8")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/gtkspell/"
+                                  version "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1zrz5pz4ryvcssk898liynmy2wyxgj95ak7mp2jv7x62yzihq6h1"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("enchant" ,enchant)
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+" ,gtk+)
+       ("pango" ,pango)))
+    (home-page "http://gtkspell.sourceforge.net")
+    (synopsis "Spell-checking addon for GTK's TextView widget")
+    (description
+     "GtkSpell provides word-processor-style highlighting and replacement of
+misspelled words in a GtkTextView widget.")
+    (license license:gpl2+)))