summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-25 03:13:55 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 17:53:48 +0200
commite220ad684f4fee5b0f9839d35603129d58791455 (patch)
tree458fd0b0661c533bfa285cd6eed59b9d03dfaf09 /gnu/packages/gtk.scm
parent8c698d7de640d2914a19f9709aeea716effb88d3 (diff)
downloadguix-e220ad684f4fee5b0f9839d35603129d58791455.tar.gz
gnu: gdk-pixbuf: Use search path instead of patching docbook schema location.
* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]: Remove phase patch-docbook.
[native-inputs]: Add LIBXML2.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d24738564c..53353dfab1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -644,20 +644,6 @@ highlighting and other features typical of a source code editor.")
        #:configure-flags '("-Dinstalled_tests=false")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-docbook
-           (lambda* (#:key native-inputs inputs #:allow-other-keys)
-             (with-directory-excursion "docs"
-               (substitute* "meson.build"
-                 (("http://docbook.sourceforge.net/release/xsl/current/")
-                  (string-append (assoc-ref (or native-inputs inputs)
-                                            "docbook-xsl")
-                                 "/xml/xsl/docbook-xsl-1.79.2/")))
-               (substitute* (find-files "." "\\.xml$")
-                 (("http://www.oasis-open.org/docbook/xml/4\\.3/")
-                  (string-append (assoc-ref ,(if (%current-target-system)
-                                                 '(or native-inputs inputs)
-                                                 'inputs) "docbook-xml")
-                                 "/xml/dtd/docbook/"))))))
          (add-before 'configure 'disable-failing-tests
            (lambda _
              (substitute* "tests/meson.build"
@@ -688,6 +674,7 @@ highlighting and other features typical of a source code editor.")
        ("gettext" ,gettext-minimal)
        ("glib" ,glib "bin")                             ; glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
+       ("libxml2" ,libxml2)             ;for XML_CATALOG_FILES
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("xsltproc" ,libxslt)))