summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 15:58:06 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 15:58:06 +0000
commitfc15512be494156f2ded624def679e2d1cc6cee7 (patch)
tree9134cbfadd40e74b09e945c9c6cbbf8ac15365b4 /gnu/packages/gtk.scm
parentdd49a72af7d8ff781be81b4b497e8ebd3a203df8 (diff)
downloadguix-fc15512be494156f2ded624def679e2d1cc6cee7.tar.gz
gnu: gtksheet: Fix build.
* gnu/packages/gtk.scm (gtksheet)[arguments]: Pass -fcommon option to GCC;
rename phase 'rename-type to 'patch-for-compatibility and update a reference
to a renamed macro.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4b953921bf..2199c3b570 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2853,7 +2853,8 @@ library for drawing.")
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list "--enable-glade"
-                               "--enable-introspection")
+                               "--enable-introspection"
+                               "CFLAGS=-fcommon")
        #:phases
        (modify-phases %standard-phases
          ;; The "configure" script is present, but otherwise the project is
@@ -2863,11 +2864,14 @@ library for drawing.")
            (lambda _
              (delete-file "configure")
              #t))
-         (add-after 'unpack 'rename-type
+         (add-after 'unpack 'patch-for-compatibility
            (lambda _
              (substitute* "glade/glade-gtksheet-editor.c"
                (("GladeEditableIface") "GladeEditableInterface"))
-             #t))
+             ;; Glade 3.37 renamed the macro GWA_GET_CLASS to
+             ;; GLADE_WIDGET_ADAPTOR_GET_ADAPTOR_CLASS.
+             (substitute* "glade/glade-gtksheet-editor.c"
+               (("GWA_GET_CLASS") "GLADE_WIDGET_ADAPTOR_GET_ADAPTOR_CLASS"))))
          ;; Fix glade install directories.
          (add-before 'bootstrap 'configure-glade-directories
            (lambda* (#:key outputs #:allow-other-keys)