summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-06-15 09:26:07 +0200
committerAndreas Enge <andreas@enge.fr>2013-06-23 22:03:57 +0200
commit527e7961252ece5d143bfd921c1159a7a5bf8d5f (patch)
tree194c7beb7a901713fc5c063b808a4d12e95bb749 /gnu/packages/gtk.scm
parentea2ddd33340e19d97308a2f05c492bbd143c6068 (diff)
downloadguix-527e7961252ece5d143bfd921c1159a7a5bf8d5f.tar.gz
gnu: Add gdk-pixbuf.
* gnu/packages/gtk.scm (gdk-pixbuf): New variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 38ad05e074..2e0a7b60b4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -27,7 +27,9 @@
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages libjpeg)
   #:use-module (gnu packages libpng)
+  #:use-module (gnu packages libtiff)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -153,3 +155,28 @@ applications. It has extensive support for the different writing systems
 used throughout the world.")
    (license license:lgpl2.0+)
    (home-page "https://developer.gnome.org/pango/")))
+
+(define-public gdk-pixbuf
+  (package
+   (name "gdk-pixbuf")
+   (version "2.28.2")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/gdk-pixbuf/2.28/gdk-pixbuf-"
+                                version ".tar.xz"))
+            (sha256
+             (base32
+              "05s6ksvy1yan6h6zny9n3bmvygcnzma6ljl6i0z9cci2xg116c8q"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("glib" ,glib)
+      ("libjpeg" ,libjpeg)
+      ("libpng" ,libpng)
+      ("libtiff" ,libtiff)
+      ("pkg-config" ,pkg-config)))
+   (synopsis "GNOME image loading and manipulation library")
+   (description
+    "GdkPixbuf is a library for image loading and manipulation developed
+in the GNOME project.")
+   (license license:lgpl2.0+)
+   (home-page "https://developer.gnome.org/gdk-pixbuf/")))