summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-30 18:57:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-30 18:57:10 +0200
commit7693f678d1de222e47af6b34ce62c41ea69934c8 (patch)
tree077a5fe0276512cbcdec27394d28c4664f0543b1 /gnu/packages/gtk.scm
parent883832b4804cde76239ceef1cdc7f9ed808435f3 (diff)
downloadguix-7693f678d1de222e47af6b34ce62c41ea69934c8.tar.gz
gnu: pango: Replace with 1.42.4.
Fixes <https://bugs.gnu.org/32594>.

* gnu/packages/gtk.scm (pango)[replacement]: New field.
(pango-1.42.4): New public variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8b11e3fb1f..6c43a3ab56 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -218,6 +218,7 @@ affine transformation (scale, rotation, shear, etc.).")
   (package
    (name "pango")
    (version "1.42.0")
+   (replacement pango-1.42.4)
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/pango/"
@@ -253,6 +254,19 @@ used throughout the world.")
    (license license:lgpl2.0+)
    (home-page "https://developer.gnome.org/pango/")))
 
+(define-public pango-1.42.4
+  (package
+    (inherit pango)
+    (version "1.42.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/pango/"
+                                  (version-major+minor version) "/"
+                                  "pango-" version ".tar.xz"))
+              (sha256
+               (base32
+                "17bwb7dgbncrfsmchlib03k9n3xaalirb39g3yb43gg8cg6p8aqx"))))))
+
 (define-public pangox-compat
   (package
     (name "pangox-compat")