summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-26 16:17:31 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-26 16:17:31 +0200
commit60ecc10f18117b5f1603d7e4d52add8a6427ab0d (patch)
treeb35692074250ad63a6fdd8c2e4d2a8ced1029275 /gnu/packages/gtk.scm
parent8ad65841030759797bf3fd39261ca17a561ec51f (diff)
downloadguix-60ecc10f18117b5f1603d7e4d52add8a6427ab0d.tar.gz
gnu: xorg-server@1.19.3: Rename to "xorg-server-for-tests".
...and update to the latest xorg-server.

* gnu/packages/gtk.scm (gtk+, gtkmm, girara): Change XORG-SERVER-1.19.3
references to XORG-SERVER-FOR-TESTS.
* gnu/packages/pdf.scm (zathura)[native-inputs]: Likewise.
* gnu/packages/xorg.scm (xorg-server-1.19.3): Rename to ...
(xorg-server-for-tests): ... this.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 38b65946b8..caa9e38a9e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -715,9 +715,9 @@ application suites.")
       ("python-wrapper" ,python-wrapper)
       ;; By using a special xorg-server for GTK+'s tests, we reduce the impact
       ;; of updating xorg-server directly on the master branch.
-      ("xorg-server" ,xorg-server-1.19.3)))
+      ("xorg-server" ,xorg-server-for-tests)))
    (arguments
-    `(#:disallowed-references (,xorg-server-1.19.3)
+    `(#:disallowed-references (,xorg-server-for-tests)
       ;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
       ;; to "doc".
       #:configure-flags (list (string-append "--with-html-dir="
@@ -1081,7 +1081,7 @@ toolkit.")
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("glib" ,glib "bin")        ;for 'glib-compile-resources'
-                     ("xorg-server" ,xorg-server-1.19.3)))
+                     ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
      `(("pangomm" ,pangomm)
        ("cairomm" ,cairomm)
@@ -1092,7 +1092,7 @@ toolkit.")
      `(;; XXX: Tests require C++14 or later.  Remove this when the default
        ;; compiler is >= GCC6.
        #:configure-flags '("CXXFLAGS=-std=gnu++14")
-       #:disallowed-references (,xorg-server-1.19.3)
+       #:disallowed-references (,xorg-server-for-tests)
        #:phases (modify-phases %standard-phases
                   (add-before 'check 'run-xvfb
                     (lambda* (#:key inputs #:allow-other-keys)
@@ -1376,7 +1376,7 @@ and routines to assist in editing internationalized text.")
                      ("check" ,check)
                      ("gettext" ,gettext-minimal)
                      ("glib:bin" ,glib "bin")
-                     ("xorg-server" ,xorg-server-1.19.3)))
+                     ("xorg-server" ,xorg-server-for-tests)))
     ;; Listed in 'Requires.private' of 'girara.pc'.
     (propagated-inputs `(("gtk+" ,gtk+)))
     (arguments