summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-04 23:25:54 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-04 23:26:43 +0200
commitb54a1b504ea44a6fa6bc708d5198b0b6f34df15c (patch)
tree15c8a89d8388f90f9e6dfbf8957e586b01d8f782 /gnu/packages/gtk.scm
parent538ca8dd65f0075cc65bcca18ed87f66a789290a (diff)
downloadguix-b54a1b504ea44a6fa6bc708d5198b0b6f34df15c.tar.gz
gnu: guile-rsvg: Use 'git-fetch' instead of a generated archive.
* gnu/packages/gtk.scm (guile-rsvg)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 24089668d2..eb1984fb20 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -943,13 +943,13 @@ exceptions, macros, and a dynamic programming environment.")
       (version (string-append "2.18.1-" revision "."
                               (string-take commit 7)))
       (source (origin
-                (method url-fetch)
-                (uri (string-append "https://gitlab.com/wingo/guile-rsvg/"
-                                    "repository/archive.tar.gz?ref="
-                                    commit))
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/wingo/guile-rsvg/")
+                      (commit commit)))
                 (sha256
                  (base32
-                  "0vdzjx8l5nc4y2xjqs0g1rqn1zrwfsm30brh5gz00r1x41a2pvv2"))
+                  "0cnbl40df2sbhpc32cma6j6w312rfvcgbxxqaixgf0ymim3fb248"))
                 (patches (search-patches "guile-rsvg-pkgconfig.patch"))
                 (modules '((guix build utils)))
                 (snippet