summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-08 13:47:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-08 14:17:57 +0100
commit7005f8cb58fd6473671e52d14b0e30cc1985721c (patch)
tree80929357c8a9d1c3f1af3f389851433666b3b3f1 /gnu/packages/gtk.scm
parent5e98d4dcce2625d44cc3a82be555504b2f87e204 (diff)
downloadguix-7005f8cb58fd6473671e52d14b0e30cc1985721c.tar.gz
gnu: harfbuzz: Update to 1.7.6.
* gnu/packages/gtk.scm (harfbuzz): Update to 1.7.6.
[native-inputs]: Add WHICH.  Replace PYTHON-2 with PYTHON-WRAPPER.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d83a5227f0..7bdc8e7cb5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -174,7 +174,7 @@ affine transformation (scale, rotation, shear, etc.).")
 (define-public harfbuzz
   (package
    (name "harfbuzz")
-   (version "1.7.5")
+   (version "1.7.6")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.freedesktop.org/software/"
@@ -182,7 +182,7 @@ affine transformation (scale, rotation, shear, etc.).")
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "0qwmybi6x27zz1bj6ccay653dh35jqq0asgvp166kjk53wdlwmw4"))))
+               "16rf7qwgy1gza74v2ws79zdwwb1lpvgz2abwwm8ws9j82cwysyys"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "bin")) ; 160K, only hb-view depend on cairo
@@ -196,7 +196,8 @@ affine transformation (scale, rotation, shear, etc.).")
    (native-inputs
     `(("gobject-introspection" ,gobject-introspection)
       ("pkg-config" ,pkg-config)
-      ("python" ,python-2))) ; incompatible with Python 3 (print syntax)
+      ("python" ,python-wrapper)
+      ("which" ,which)))
    (arguments
     `(#:configure-flags `("--with-graphite2"
                           "--with-gobject"