summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authordoncatnip <gnopap@gmail.com>2016-09-01 03:15:01 +0200
committer宋文武 <iyzsong@gmail.com>2016-09-04 15:08:58 +0800
commit37355498e677fbb5f736e825b7e8f5055e7496b4 (patch)
tree885adda3f0e5f82fe1fa943a81827ebf5e034d5c /gnu/packages/gtk.scm
parent69913ed0e62692ff149e312434980c2fc2c1ac89 (diff)
downloadguix-37355498e677fbb5f736e825b7e8f5055e7496b4.tar.gz
gnu: gtk: Add clipit.
* gnu/packages/gtk.scm (clipit): New variable.

Co-authored-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 396ff1f1d0..74c4ed36a9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1333,3 +1333,29 @@ glass artworks done by Venicians glass blowers.")
      "GtkSpell provides word-processor-style highlighting and replacement of
 misspelled words in a GtkTextView widget.")
     (license license:gpl2+)))
+
+(define-public clipit
+  (package
+    (name "clipit")
+    (version "1.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/downloads/ClipIt/clipit-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0jrwn8qfgb15rwspdp1p8hb1nc0ngmpvgr87d4k3lhlvqg2cfqva"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk+" ,gtk+-2)))
+    (home-page "https://github.com/CristianHenzel/ClipIt")
+    (synopsis "Lightweight GTK+ clipboard manager")
+    (description
+     "ClipIt is a clipboard manager with features such as a history, search
+thereof, global hotkeys and clipboard item actions.  It was forked from
+Parcellite and adds bugfixes and features.")
+    (license license:gpl2+)))