summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-27 05:23:27 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:28 -0400
commit0c0fc32681a497d61f4c9bd12e3510652a169ab2 (patch)
tree2d78bd16b8467c25c86982a72258d0b231e70a62 /gnu/packages/gtk.scm
parenta06a36401eddf4c28402cd53eeeb2a888885b57c (diff)
downloadguix-0c0fc32681a497d61f4c9bd12e3510652a169ab2.tar.gz
gnu: gtkmm: Change build-system and adjust arguments accordingly.
Switch to meson-build-system, as its preferred by the project.
Preserve building of documentation.

* gnu/packages/gtk.scm (gtkmm)[build-system]: Change from glib-or-gtk
to meson.
[configure-flags](build-documentation): New flag.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 869246c36d..c88eef3f92 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1609,10 +1609,11 @@ library.")
                        name "-" version ".tar.xz"))
        (sha256
         (base32 "0hv7pviln4cpjvpz7m7ga5krcsbibqzixdcn0dwzpz0cx71p3swv"))))
-    (build-system glib-or-gtk-build-system)
+    (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
-     `(#:phases
+     `(#:configure-flags '("-Dbuild-documentation=true")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda _