summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-09-06 20:53:19 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-07 15:13:08 -0400
commit3856817ede1e09eaa2425476eb2108b0f75f944d (patch)
tree7d60bf10e74fcdbd84512203b038c1610dbbc690 /gnu/packages/gtk.scm
parentda2b1ab03098a05e4c72ba1418743152b831c82e (diff)
downloadguix-3856817ede1e09eaa2425476eb2108b0f75f944d.tar.gz
gnu: gtksourceview@3: Adjust inherited fields and update to 3.24.11.
* gnu/packages/gtk.scm (gtksourceview-3)[version]: Update to 3.24.11.
[build-system]: New field.
[arguments]: New field.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm36
1 files changed, 34 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b815c8e2ee..50dc3d199e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -614,7 +614,7 @@ highlighting and other features typical of a source code editor.")
 (define-public gtksourceview-3
  (package (inherit gtksourceview)
    (name "gtksourceview")
-   (version "3.24.10")
+   (version "3.24.11")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnome/sources/" name "/"
@@ -622,7 +622,39 @@ highlighting and other features typical of a source code editor.")
                                  name "-" version ".tar.xz"))
              (sha256
               (base32
-               "16ym7jwiki4s1pilwr4incx0yg7ll94f1cajrnpndkxxs36hcm5b"))))))
+               "1zbpj283b5ycz767hqz5kdq02wzsga65pp4fykvhg8xj6x50f6v9"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:configure-flags
+      (list
+       ,@(if (%current-target-system)
+             ;; If true, gtkdoc-scangobj will try to execute a
+             ;; cross-compiled binary.
+             '("--disable-gtk-doc")
+             '("--enable-gtk-doc"))
+       (string-append "--with-html-dir="
+                      (assoc-ref %outputs "doc")
+                      "/share/gtk-doc/html"))
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'patch-docbook-xml
+          (lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
+            (substitute* (find-files "docs" "\\.xml\\.in$")
+              (("http://www.oasis-open.org/docbook/xml/4.3/")
+               (string-append
+                (assoc-ref (or native-inputs inputs) "docbook-xml-4.3")
+                "/xml/dtd/docbook/")))))
+        (add-before 'check 'pre-check
+          (lambda _
+            ;; Tests require a running X server.
+            (system "Xvfb :1 +extension GLX &")
+            (setenv "DISPLAY" ":1")
+            ;; Tests write to $HOME.
+            (setenv "HOME" (getcwd))
+            ;; Tests look for $XDG_RUNTIME_DIR.
+            (setenv "XDG_RUNTIME_DIR" (getcwd))
+            ;; For missing '/etc/machine-id'.
+            (setenv "DBUS_FATAL_WARNINGS" "0"))))))))
 
 (define-public gdk-pixbuf
   (package