summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2018-09-08 22:54:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 14:45:15 +0200
commit57d70dbabc5a274a63c0a2892bbd739520774f7a (patch)
tree495ecdac028c923e1517ce01b9a897252be410cb /gnu/packages/gtk.scm
parent94b3b6041d8b141b99e79f4cf95c5a31a3739d17 (diff)
downloadguix-57d70dbabc5a274a63c0a2892bbd739520774f7a.tar.gz
gnu: Add yad.
* gnu/packages/gtk.scm (yad): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4daaad0ebc..0b85a1723f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1658,3 +1658,46 @@ Parcellite and adds bugfixes and features.")
 it does not deal with windowing system surfaces, drawing, scene graphs, or
 input.")
     (license license:expat)))
+
+(define-public yad
+  (package
+    (name "yad")
+    (version "0.40.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/v1cont/yad.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vpgbjbkkbk5plicyklzpf65j1vlig4n4bi3qpvrz5bb09ic5alw"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       '("--with-gtk=gtk3"
+         "--enable-html"
+         "--enable-gio"
+         "--enable-spell"
+         "--enable-icon-browser")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'bootstrap
+           (lambda _
+             (invoke "autoreconf" "-vif")
+             (invoke "intltoolize" "--force" "--automake")
+             #t)))))
+    (inputs
+     `(("gtk+" ,gtk+)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://sourceforge.net/projects/yad-dialog/")
+    (synopsis "GTK+ dialog boxes for shell scripts")
+    (description
+     "This program allows you to display GTK+ dialog boxes from command line or
+shell scripts.  Example of how to use @code{yad} can be consulted at
+@url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
+    (license license:gpl3+)))