summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-18 00:37:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-18 00:39:25 +0100
commitff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30 (patch)
treec6a0693694b3b7d93de3fa2c8eef099bc08e66ad /gnu/packages/gtk.scm
parent6f6db0269f76525e91201038b77798d666c8130b (diff)
parenta01d926f9d10bb504ae4304567924e43368d4954 (diff)
downloadguix-ff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e82958cee3..2939e4f648 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1254,7 +1254,7 @@ write GNOME applications.")
                      ("check" ,check)
                      ("gettext" ,gettext-minimal)
                      ("glib:bin" ,glib "bin")
-                     ("xorg-server" ,xorg-server)))
+                     ("xorg-server" ,xorg-server-1.19.3)))
     ;; Listed in 'Requires.private' of 'girara.pc'.
     (propagated-inputs `(("gtk+" ,gtk+)))
     (arguments
@@ -1262,6 +1262,7 @@ write GNOME applications.")
        `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
          "COLOR=0" "CC=gcc")
        #:test-target "test"
+       #:disallowed-references (,xorg-server-1.19.3)
        #:phases (modify-phases %standard-phases
                   (delete 'configure)
                   (add-before 'check 'start-xserver
@@ -1270,6 +1271,11 @@ write GNOME applications.")
                       (let ((xorg-server (assoc-ref inputs "xorg-server"))
                             (display ":1"))
                         (setenv "DISPLAY" display)
+
+                        ;; On busy machines, tests may take longer than
+                        ;; the default of four seconds.
+                        (setenv "CK_DEFAULT_TIMEOUT" "20")
+
                         ;; Don't fail due to missing '/etc/machine-id'.
                         (setenv "DBUS_FATAL_WARNINGS" "0")
                         (zero? (system (string-append xorg-server "/bin/Xvfb "