summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-05 22:38:50 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-05 22:42:26 +0100
commit2561f2720f6afdab47991e6430dc8a1215a27bc7 (patch)
tree7f8dea2d941ffa9857c026a05d4fa1616fedfe07 /gnu/packages/gtk.scm
parent3bd7ce60530ad363e235f458ecbe2bcc9454242a (diff)
downloadguix-2561f2720f6afdab47991e6430dc8a1215a27bc7.tar.gz
gnu: gtk+: Use 'librsvg-for-system'.
This brings back SVG support on non-x86_64 platforms.

* gnu/packages/gtk.scm (gtk+)[inputs]: Use 'librsvg-for-system'
unconditionally.
[arguments]: In 'disable-failing-tests' phase, remove conditional
substitutions aimed for non-x86_64 targets lacking librsvg support.
* gnu/packages/gnome.scm (libhandy)[arguments]: Likewise, remove
'skip-test-that-requires-svg' phase.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b69fa372d9..05e5165d3f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -966,11 +966,7 @@ application suites.")
        ("fribidi" ,fribidi)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
-       ;; SVG support is optional and requires librsvg, which pulls in rust.
-       ;; Rust is not supported well on every architecture yet.
-       ("gdk-pixbuf" ,(if (target-x86-64?)
-                          librsvg
-                          gdk-pixbuf))
+       ("gdk-pixbuf" ,(librsvg-for-system))
        ("glib" ,glib)
        ("libcloudproviders" ,libcloudproviders-minimal)
        ("libepoxy" ,libepoxy)
@@ -1045,19 +1041,10 @@ application suites.")
                (("notify no-gtk-init object objects-finalize papersize rbtree")
                 "no-gtk-init papersize rbtree")
                (("stylecontext templates textbuffer textiter treemodel treepath")
-                "stylecontext textbuffer textiter treemodel treepath")
-               ;; The ‘icontheme’ test needs SVG support.
-               ,@(if (not (target-x86-64?))
-                     '((("floating focus gestures grid gtkmenu icontheme keyhash listbox")
-                        "floating focus gestures grid gtkmenu keyhash listbox"))
-                     '()))
+                "stylecontext textbuffer textiter treemodel treepath"))
              (substitute* "testsuite/a11y/Makefile.in"
                (("accessibility-dump tree-performance text children derive")
-                "tree-performance text children derive")
-               ,@(if (not (target-x86-64?))
-                     '((("value misc tree-relationships util")
-                        "value misc util"))
-                     '()))
+                "tree-performance text children derive"))
              (substitute* "testsuite/reftests/Makefile.in"
                (("TEST_PROGS = gtk-reftest")
                 "TEST_PROGS = "))