summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-05 23:15:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-05 23:15:24 +0100
commit597119937d7399a45f2fa5c0e53e382a291ee2da (patch)
tree47027d4c45a6468e8612e8e4790268f15acb65e5 /gnu/packages/gtk.scm
parent90570b5e9f3da11a63e7c7865d44daddf2e366b5 (diff)
downloadguix-597119937d7399a45f2fa5c0e53e382a291ee2da.tar.gz
gnu: gtk+@2: Use 'librsvg-for-system'.
* gnu/packages/gtk.scm (gtk+-2)[propagated-inputs]: Use
'librsvg-for-system' unconditionally.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 05e5165d3f..38ac6c526c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -863,12 +863,7 @@ is part of the GNOME accessibility project.")
     (propagated-inputs
      `(("atk" ,atk)
        ("cairo" ,cairo)
-       ;; SVG support is optional and requires librsvg, which pulls in rust.
-       ;; Rust is not supported well on every architecture yet.
-       ("gdk-pixbuf" ,(if (string-prefix? "x86_64" (or (%current-target-system)
-                                                       (%current-system)))
-                          librsvg
-                          gdk-pixbuf))
+       ("gdk-pixbuf" ,(librsvg-for-system))
        ("glib" ,glib)
        ("pango" ,pango)))
     (inputs