summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 13:59:19 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:08 +0000
commitb79bf535e48c9f0e012fa7a88a408945b2db9a01 (patch)
tree1c0a91dbd5b3478d2d30a9fe6fd2edd46e8f2d7a /gnu/packages/gtk.scm
parent0636f02b0e33aed9b2f951bc91ded0fe8a7d1654 (diff)
downloadguix-b79bf535e48c9f0e012fa7a88a408945b2db9a01.tar.gz
gnu: at-spi2-core: Don't cross-compile documentation.
* gnu/packages/gtk.scm
  (at-spi2-core)[arguments]<#:configure-flags>: Set docs=false when
  cross-compiling.
  (at-spi2-core)[arguments]<#:phases>{move-documentation}: Remove when
  cross-compiling.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm30
1 files changed, 18 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 12132db50c..227e0b4f99 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -724,9 +724,13 @@ scaled, composited, modified, saved, or rendered.")
     (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
-     '(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
+     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:configure-flags
-       (list "-Ddocs=true")
+       ;; Generating documentation requires running binaries for the host
+       ;; on the build machine.
+       (list ,(if (%current-target-system)
+                  "-Ddocs=false"
+                  "-Ddocs=true"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-documentation-path
@@ -748,16 +752,18 @@ scaled, composited, modified, saved, or rendered.")
                  (("http://.*/docbookx\\.dtd")
                   (string-append xmldoc "/docbookx.dtd")))
                #t)))
-         (add-after 'install 'move-documentation
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (doc (assoc-ref outputs "doc")))
-               (copy-recursively
-                (string-append out "/share/gtk-doc")
-                (string-append doc "/share/gtk-doc"))
-               (delete-file-recursively
-                (string-append out "/share/gtk-doc")))
-             #t))
+         ,@(if (%current-target-system)
+               '()
+               '((add-after 'install 'move-documentation
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     (let ((out (assoc-ref outputs "out"))
+                           (doc (assoc-ref outputs "doc")))
+                       (copy-recursively
+                        (string-append out "/share/gtk-doc")
+                        (string-append doc "/share/gtk-doc"))
+                       (delete-file-recursively
+                        (string-append out "/share/gtk-doc")))
+                     #t))))
          (add-after 'install 'check
            (lambda _
              (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME