summary refs log tree commit diff
path: root/gnu/packages/guile-wm.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-12-04 21:48:44 +0000
committerKei Kebreau <kkebreau@posteo.net>2017-12-07 11:23:27 -0500
commit7b45392616ad5842c278441cb8443febefccc6ae (patch)
treeed37478c44ea4005fdb40991608d453093fd30f3 /gnu/packages/guile-wm.scm
parent0504daaace5252a123828319db676eba197c9882 (diff)
downloadguix-7b45392616ad5842c278441cb8443febefccc6ae.tar.gz
gnu: guile-wm: Update to 1.0-1.f3c7b3b.
* gnu/packages/guile-wm.scm (guile-xcb): Update to 1.0-1.f3c7b3b.
(version): Use git-version.
(source): Switch to git-fetch.
(native-inputs): Add texinfo.
(home-page): Update to new location.

Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages/guile-wm.scm')
-rw-r--r--gnu/packages/guile-wm.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 7a810ad529..7f302668ab 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -71,18 +71,21 @@ dependencies.")
     (license gpl3+))))
 
 (define-public guile-wm
+  (let ((commit "f3c7b3be719f425ffb87265d34855a73366351be")
+        (revision "1"))
   (package
     (name "guile-wm")
-    (version "1.0")
+    (version (git-version "1.0" revision commit))
     (synopsis "X11 window manager toolkit in Scheme")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "http://web.archive.org/web/20161005084324/"
-                                  "http://www.markwitmer.com/dist/guile-wm-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mwitmer/guile-wm")
+                    (commit commit)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1l9qcz236jxvryndimjy62cf8zxf8i3f8vg3zpqqjhw15j9mdk3r"))))
+                "086dijnpl5dpglf70d6f9sizyakr313y7blpdjrmbi687j1x3qcl"))))
     (build-system gnu-build-system)
     (arguments
      `( ;; The '.scm' files go to $(datadir), so set that to the
@@ -135,14 +138,15 @@ dependencies.")
                                     Type=Application~%"
                           ,name ,synopsis %output))))
              #t)))))
-    (native-inputs `(("pkg-config" ,pkg-config)))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("texinfo" ,texinfo)))
     (inputs `(("guile" ,guile-2.0)
               ("guile-xcb" ,guile-xcb)))
-    (home-page "http://www.markwitmer.com/guile-xcb/guile-wm.html")
+    (home-page "https://github.com/mwitmer/guile-wm/releases")
     (description
      "Guile-WM is a simple window manager that's completely customizable—you
 have total control of what it does by choosing which modules to include.
 Included with it are a few modules that provide basic TinyWM-like window
 management, some window record-keeping, multi-monitor support, and emacs-like
 keymaps and minibuffer.  At this point, it's just enough to get you started.")
-    (license gpl3+)))
+    (license gpl3+))))