summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-02 18:19:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 12:52:56 +0100
commit6c39c131b74651e3019cd199061fcfc3607ba198 (patch)
tree838d0937588ca5202a6d7a2f5871902c9de9441e /gnu/packages/guile-xyz.scm
parentc258637b84e612f582b471ed9add54697ccca289 (diff)
downloadguix-6c39c131b74651e3019cd199061fcfc3607ba198.tar.gz
gnu: guile-gi: Fix a source code encoding error.
* gnu/packages/guile-xyz.scm (guile-gi)[phases]: Remove the default dotted
circle from the combining character that is tested in test/string.scm.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 355b23f57e..e3c36ff60e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3142,6 +3142,16 @@ list of components.  This module takes care of that for you.")
                   (ice-9 rdelim))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'remove-dotted-circle-from-combining-character
+           ;; The test/string.scm files contain ◌̀, which is a dotted circle
+           ;; (U+25cc) followed by an upper combining character (U+0300). The
+           ;; old guile 3.0.2 reader incorrectly ignores the dotted circle,
+           ;; and parses it as the combining character alone, but the new
+           ;; guile reader does not.
+           ;; See https://github.com/spk121/guile-gi/issues/112
+           (lambda* _
+             (substitute* "test/string.scm"
+               (("#\\\\◌̀") "#\\x0300"))))
          (add-after 'unpack 'patch-references-to-extension
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((effective (read-line