summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-01 15:56:06 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-01 16:05:16 +0100
commitdf78f622791ea6f832ce0c54f6aaf8f6e58319d1 (patch)
tree58662a45569bc5642fd52c791c4c8b8d8908f2bf /gnu/packages/guile-xyz.scm
parentd08d629964134133184ef18550aa45aa8ef38463 (diff)
downloadguix-df78f622791ea6f832ce0c54f6aaf8f6e58319d1.tar.gz
gnu: guile-gi: Depropagate inputs needed for testing only.
* gnu/packages/guile-xyz.scm (guile-gi)[propagated-inputs]: Remove
gsettings-desktop-schemas and guile-lib.  Move glib, gtk+ and webkitgtk from
here...
[inputs]: ... to here.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d62590aff6..74567830e6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2965,6 +2965,7 @@ list of components.  This module takes care of that for you.")
                   (guix build utils)
                   (ice-9 popen)
                   (ice-9 rdelim))
+       #:disallowed-references ,(list gtk+ webkitgtk)
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'remove-dotted-circle-from-combining-character
@@ -3007,14 +3008,10 @@ list of components.  This module takes care of that for you.")
      (list gettext-minimal
            `(,glib "bin") ; for glib-compile-resources
            libtool pkg-config xorg-server))
-    (propagated-inputs
-     (list glib
-           gobject-introspection
-           gsettings-desktop-schemas
-           gtk+
-           guile-lib
-           webkitgtk))
-    (inputs (list guile-3.0))
+    (propagated-inputs (list gobject-introspection))
+    (inputs (list guile-3.0 glib
+                  ;; For tests, only relevant when compiling natively
+                  gtk+ webkitgtk))
     (home-page "https://github.com/spk121/guile-gi")
     (synopsis "GObject bindings for Guile")
     (description