summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-08 11:48:01 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-08 11:48:01 +0200
commita605ef3ce9dbd6b79dd9322f89d9facaf875b487 (patch)
treecabb9aa74f3f0e0dd35386cd9800fa688264576c /gnu/packages/guile.scm
parent7b7bc91c3d7fba306884cd1681d12b51246c2aea (diff)
downloadguix-a605ef3ce9dbd6b79dd9322f89d9facaf875b487.tar.gz
gnu: libgc@8: Build with '--disable-munmap'.
Partially fixes <https://bugs.gnu.org/40525>.

* gnu/packages/bdw-gc.scm (libgc)[arguments]: Configure with
'--disable-munmap'.
* gnu/packages/guile.scm (guile-3.0/libgc-7): Remove.
* gnu/packages/ci.scm (cuirass)[inputs]: Refer to GUILE-3.0-LATEST
instead of GUILE-3.0/LIBGC-7.
* guix/self.scm (specification->package): Likewise.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index fdda6cd733..5bef56a891 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -319,17 +319,6 @@ without requiring the source code to be rewritten.")
   ;; The latest 3.0.x version.
   guile-3.0)
 
-(define-public guile-3.0/libgc-7
-  ;; Using libgc-7 avoid crashes that can occur, particularly when loading
-  ;; data in to the Guix Data Service:
-  ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40525
-  (hidden-package
-   (package
-     (inherit guile-3.0-latest)
-     (propagated-inputs
-      `(("bdw-gc" ,libgc-7)
-        ,@(srfi-1:alist-delete "bdw-gc" (package-propagated-inputs guile-3.0)))))))
-
 (define-public guile-3.0/fixed
   ;; A package of Guile that's rarely changed.  It is the one used in the
   ;; `base' module, and thus changing it entails a full rebuild.